Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-07-2011, 10:07 PM   #15
Senior Member
 
tderonne's Avatar
 
Join Date: Dec 2003
Location: Motor City, Mich
Posts: 2,303
All '99 and up F53's have catalysts. The early ones (up to at least '04) were certified to ODBI and didn't have downstream sensors to monitor it, but they are there.
__________________

__________________
Tim.

tderonne is online now   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-07-2011, 10:39 PM   #16
Senior Member
 
Wanabee FTer's Avatar
 
Gulf Streamers Club
Ford Super Duty Owner
Join Date: Jul 2010
Location: Golden Village Palms, CA
Posts: 1,988
Blog Entries: 12
Quote:
Originally Posted by tderonne View Post
All '99 and up F53's have catalysts. The early ones (up to at least '04) were certified to ODBI and didn't have downstream sensors to monitor it, but they are there.
Sorry, working with my failing memory. It's the rear (downstream) O2 sensor that was not used in early V-10 production, It does have a single cat converter mounted right after the Y-pipe.
__________________

__________________
John
'98 Gulf Stream Sunsport 325, 7.5L Banks Power Pack, Koni FSD's, Air Bags, ReadyBrute Elite,
2000 Honda Accord

Wanabee FTer is offline   Reply With Quote
Old 09-08-2011, 06:10 AM   #17
Senior Member
 
tderonne's Avatar
 
Join Date: Dec 2003
Location: Motor City, Mich
Posts: 2,303
Just want to be sure the OP knows his catalyst is missing.
__________________
Tim.

tderonne is online now   Reply With Quote
Old 09-08-2011, 08:48 AM   #18
Senior Member
 
Dunner's Avatar
 
Join Date: Jun 2011
Location: Phx, Arid~zona
Posts: 11,106
Quote:
Originally Posted by meant2shop View Post
Thank you both for the info. I forgot to add that our rig does not have a catalytic converter (none required in previous owner's county in GA and none required in our county in OR).

Would we still need to have the o2 sensor, egr, or the "evap" checked out? Can we eliminate any of the 3, since we don't have a catalytic converter?

Presently, hubbie just disconnects the engine battery for about 5 minutes or so, reconnects, and the engine light stays off for awhile (like for 100 miles or so).

Thanks
Quote:
Originally Posted by tderonne View Post
Just want to be sure the OP knows his catalyst is missing.
I think the OP already covered that.
__________________
2004 32' National Sea Breeze 1311 Class A on a F-53 Chassis, CHF, TST TPMS, 5Star Tune.
If Dunner (RVM23) can't fix it, it ain't broke!
Cheap Handling Fix Poll. Click Here to vote?
Dunner is offline   Reply With Quote
Old 09-08-2011, 09:14 AM   #19
Senior Member
 
Rick Long's Avatar
 
Fleetwood Owners Club
Solo Rvers Club
Join Date: Dec 2007
Location: Some Place
Posts: 1,161
Send a message via Yahoo to Rick Long
Most Auto Parts stores will read the code for you for free... GET IT DONE!!
I had a "Service Engine Soon" light pop up on my 1999, V10 and thought it just meant it I needed an oil change.

SHOCK!!!!!!! I had two codes and none where good. One said the number 3 cylinder was NOT firing... the second code said the computer couldn't correct the rich fuel problem and was not functioning properly.

I found the problem with number 3 cylinder and fixed it but the light came back on and stayed on for my trip of 640 miles.. then it finally went out and all the sudden my gas mileage went back to normal.
__________________

__________________
1999 Fleetwood Bounder 32H
Many Places Full Time
No Dog * No Cat * No Co-Pilot
Rick Long is offline   Reply With Quote
Reply

Tags
ford, v10



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine light wilpower Monaco Owner's Forum 2 09-02-2010 03:16 PM
Engine Check Light kketterling Monaco Owner's Forum 23 08-20-2010 02:54 PM
Check Engine Light Came On Wayne M Cummins Engines 6 06-28-2010 11:18 PM
C7 350HP Check Engine Light BBBEEBOP Caterpillar Engine Forum 5 05-03-2010 09:10 AM
Check engine light gwedgewo Winnebago Industries Owner's Forum 4 06-23-2007 12:09 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:45 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.