Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-06-2008, 11:34 AM   #1
Junior Member
 
Join Date: Sep 2008
Posts: 15
hi all,

I recently rebuilt the carb (rochester 4MC) on my 350 MH engine. I took some pics but the memory card has corrupted

I cannot even get close with the vacuum lines and where they go.

The van runs well, but is horrible when cold, plumes of black smoke suggesting very rich running.

I have a chilton and haynes manual, but still cant trace the diagrams very well

Has anyone got a picture of the top of their 350 engine, or could take one? (airfilter removed)

I would be so grateful!

John
__________________

__________________
John_uk is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-06-2008, 11:34 AM   #2
Junior Member
 
Join Date: Sep 2008
Posts: 15
hi all,

I recently rebuilt the carb (rochester 4MC) on my 350 MH engine. I took some pics but the memory card has corrupted

I cannot even get close with the vacuum lines and where they go.

The van runs well, but is horrible when cold, plumes of black smoke suggesting very rich running.

I have a chilton and haynes manual, but still cant trace the diagrams very well

Has anyone got a picture of the top of their 350 engine, or could take one? (airfilter removed)

I would be so grateful!

John
__________________

__________________
John_uk is offline   Reply With Quote
Old 10-07-2008, 08:59 AM   #3
Senior Member
 
Workhorse Chassis Owner
Join Date: Sep 2007
Location: st.charles mo.
Posts: 1,194
The engine is running rich when cold is probably caused by the choke pulloff not working or needs adjusting. When the engine starts the choke pulloff get manifold vac.and opens the choke a small amount. If it is getting vac. you can manualy open the choke till it runs clean and then adjust the pulloff to that point.
__________________
speed racer is offline   Reply With Quote
Old 10-07-2008, 10:58 AM   #4
Junior Member
 
Join Date: Sep 2008
Posts: 15
thanks SR

Well I made progress of sorts...
I pulled the carb off just now and it turns out the fast idle wasn't adjusted properly..(there was none!)

that wouldn't have helped the running..

also the rear vac wasn't opening with vacuum applied..

I have the revs sky high ow even after 3 adjusts on the fast idle and one on the hot idle, so have given up for tonight.
Think I need to put carb back on bench and do lots of measuring now..
__________________
John_uk is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 Chevy or GMC Gasser RKamperRV Trailer Towing and Tow Vehicles Discussion 28 03-25-2009 04:59 PM
Dexter Elec Hydra Disc Brakes & Ford, GMC, Chevy LIKENIT Trailer Towing and Tow Vehicles Discussion 7 08-06-2007 07:29 PM
Mileage of GMC 6.0 l VMT engine wakamicamper Trailer Towing and Tow Vehicles Discussion 4 07-25-2007 04:54 PM
2007 GMC or Chevy 1500 4X4 Pickup Toad Howard Leap Toads and Motorhome Related Towing 10 04-25-2007 07:01 PM
GMC/Chevy E brake problem? Tootall Trailer Towing and Tow Vehicles Discussion 6 09-08-2006 06:23 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:07 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.