Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-23-2014, 08:48 PM   #1
Junior Member
 
Join Date: Jul 2013
Location: Shepherdsville Ky
Posts: 16
Class A Generac 7500 No Power

Hi All, I have a 2005 Damon with gaurdian 7500 diesel genset, I unplugged from the house and fired up genset, turned on both AC's and waited a bit everything seemed fine. without thinking I hit the switch in the bedroom and shutdown genset under a load. dumb... I turned off AC's and started Gen Backup, turned on AC's and left them to cool down the coach walking to garage heard genset start to drag down almost sputtering, and coughing, then it ran back up to speed, went into coach looked around and found rear AC had flipped breaker. I reset the breaker AC seemed OK so I shut all down and quit for the day, went out early this A.M did some cleaning, started Genset engine runs fine but no power. checked at the switchgear and only getting 42 V on both poles of genset connection. Help!!!!!!!!!!! Any Ideas????????? only 29 hours on Genset and 15000 miles on coach.
__________________

__________________
jcbinky is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-23-2014, 09:31 PM   #2
Senior Member
 
gemini5362's Avatar
 
Tiffin Owners Club
Freightliner Owners Club
Join Date: Apr 2012
Posts: 2,078
Did you reset the circuit breakers on the genset itself ?
__________________

__________________
gemini5362 is offline   Reply With Quote
Old 06-23-2014, 09:48 PM   #3
Junior Member
 
Join Date: Jul 2013
Location: Shepherdsville Ky
Posts: 16
Yes reset all breakers in coach and on genset
__________________
jcbinky is offline   Reply With Quote
Old 06-23-2014, 09:55 PM   #4
Senior Member
 
TonyDi's Avatar


 
Join Date: Feb 2011
Location: Point Pleasant Beach, NJ
Posts: 10,400
Are you getting 110v on anything or is it just the AC that's out? Your inverter also has breakers on it check them too. Be sure to check your GFI plugs too. Best of luck.
__________________
Tony & Ruth........... FMCA#F416727
Newmar Dutch Star 4320, Spartan MM Chassis, Cat C9, Jeep Grand Cherokee Hemi, Blue Ox Aventa LX, and Brake Buddy. TST 507 TPMS
TonyDi is offline   Reply With Quote
Old 06-23-2014, 10:16 PM   #5
Junior Member
 
Join Date: Jul 2013
Location: Shepherdsville Ky
Posts: 16
Everything works on shore power, nothing works on Genset, checked at switchgear and only getting 42 volts on each pole of genset.
__________________
jcbinky is offline   Reply With Quote
Old 06-24-2014, 03:56 AM   #6
Senior Member
 
94-Newmar's Avatar
 
Join Date: Nov 2009
Posts: 2,043
Does your meter have the ability to read hertz? HZ

Need to know if the cycles are ok at 59-61HZ even if the AC voltage is low... also can you post your full model number?
__________________
94-Newmar Kountry Star 40-KSDP
Spartan/Cummins 8.3C-300HP/Allison 3060 WTEC-II/25yr RV Tech RVIA Certified/Onan-Cummins Certified
94-Newmar is offline   Reply With Quote
Old 06-24-2014, 06:41 AM   #7
Junior Member
 
Join Date: Jul 2013
Location: Shepherdsville Ky
Posts: 16
Full Model Number Is 004270-2
Gaurdian Quietpac 75D

No my multimeter wont read hertz
__________________
jcbinky is offline   Reply With Quote
Old 06-24-2014, 06:43 AM   #8
Junior Member
 
Join Date: Jul 2013
Location: Shepherdsville Ky
Posts: 16
I know i read -0- Voltage on the two generator poles at the switch gear when generator is off and show 42 volts when running,
__________________
jcbinky is offline   Reply With Quote
Old 06-24-2014, 06:56 AM   #9
Senior Member
 
94-Newmar's Avatar
 
Join Date: Nov 2009
Posts: 2,043
Yes but it's imperative to know if it's producing any HZ so that we can better determine if its a voltage regulator issue, excitation issue, flash voltage, brushes/slip ring issue or even perhaps a winding issue in the stator. Perhaps you can find or borrow one to use?
__________________
94-Newmar Kountry Star 40-KSDP
Spartan/Cummins 8.3C-300HP/Allison 3060 WTEC-II/25yr RV Tech RVIA Certified/Onan-Cummins Certified
94-Newmar is offline   Reply With Quote
Old 06-24-2014, 07:12 AM   #10
Senior Member
 
94-Newmar's Avatar
 
Join Date: Nov 2009
Posts: 2,043
One thing you can look for pretty quick until you locate a meter able to read Hertz (HZ)...With the genset OFF look inside the control panel there is a small self-resetting circuit breaker, rectangular in size there will only be two wires on it. One of the wires leading to it may be marked as number 2... remove either of the wires. Set your voltmeter to OHMS and meter across the two terminals. You should read continuity or infinite ohms across this breaker. If it reads open then it has failed.

This breaker protects the windings in the stator and will prevent excitation voltage passing to the rotor and voltage regulator, thus causing your poor output voltage - the unit will still produce 60HZ power in this state, but will not be able to bump it's voltage much past 30-40 volts or so. IF this self-resetting breaker is ok, then we can dive in a bit further.
__________________
94-Newmar Kountry Star 40-KSDP
Spartan/Cummins 8.3C-300HP/Allison 3060 WTEC-II/25yr RV Tech RVIA Certified/Onan-Cummins Certified
94-Newmar is offline   Reply With Quote
Old 06-24-2014, 07:51 AM   #11
Junior Member
 
Join Date: Jul 2013
Location: Shepherdsville Ky
Posts: 16
Checked the exitation breaker it reads infinite or -0.00 ohms closed. shows good
__________________
jcbinky is offline   Reply With Quote
Old 06-24-2014, 12:32 PM   #12
Junior Member
 
Join Date: Jul 2013
Location: Shepherdsville Ky
Posts: 16
Checked Voltage at Genset Junction Box In front Still 41 Volts on each leg. Hertz less than 1 actual test was 0.382 leg black 0.418 leg red, shutdown gen and plugged in shore power hertz 60.0 black 59.9 leg red. at the shore power connection in switchgear.

Checked the exitation breaker it reads infinite or -0.00 ohms closed. shows good
__________________
2005 Damon Astoria 38 foot 300 Cummins.
Cummins, Detroit, Allison, Caterpillar, Certified Retired Whayne Supply Co Caterpillar.
jcbinky is offline   Reply With Quote
Old 06-24-2014, 04:41 PM   #13
Junior Member
 
Join Date: Jul 2013
Location: Shepherdsville Ky
Posts: 16
I am thinking voltage regulator. fixed excitation test showed 87 volts on wire 2&6 87 volts wire 11&22 amp draw good , wire 4 continuity good,
__________________
2005 Damon Astoria 38 foot 300 Cummins.
Cummins, Detroit, Allison, Caterpillar, Certified Retired Whayne Supply Co Caterpillar.
jcbinky is offline   Reply With Quote
Old 06-24-2014, 07:01 PM   #14
Senior Member
 
94-Newmar's Avatar
 
Join Date: Nov 2009
Posts: 2,043
Yes, but the voltage regulator has absolutely nothing to do with the HZ... just voltage. You could have 10 volts at 60HZ and then I would agree that the voltage regulator needs looked at in more detail. But with only 1hz I'm leaning towards checking windings......

Did you externally excite it? Did you try both 12 and 24 volts?
__________________

__________________
94-Newmar Kountry Star 40-KSDP
Spartan/Cummins 8.3C-300HP/Allison 3060 WTEC-II/25yr RV Tech RVIA Certified/Onan-Cummins Certified
94-Newmar is offline   Reply With Quote
Reply

Tags
class a, power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No 12v power when shore power not connected bvaughn4 Damon 20 08-30-2014 01:54 PM
No Power to antenna figallegro Newmar Owner's Forum 9 05-12-2014 08:45 AM
Chassis & engines on Class Cs vs Class As SissyBoyBob MH-General Discussions & Problems 4 04-14-2014 05:10 PM
RV of the Year Awarded to Thor Motor Coach Class A RUV Motorhomes DriVer RV Industry Press 0 12-12-2013 01:00 PM
Best Selling Motorhome Manufacturer Unveils New 2014 Class A Motor Home DriVer RV Industry Press 2 08-21-2013 09:13 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:14 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.