Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-29-2008, 08:27 AM   #1
Senior Member
 
Join Date: Sep 2001
Posts: 219
Used it at one campground and the next time I hooked up it wouldn't work. It has propane to the regulator as it hiss/pops when taking the hose off. When I hook the regulator onto the grill and open the burner to lite, I get a quick burst of propane (hiss) and then nothing more. Something seems to sop it. I run it off of the motorhome tank, but like I said, there is propane in the line. The other appliance (stove) runs OK. I have turned the propane tank off and then slowly back on, but still nothing. Anything else I can try???
__________________

__________________
Barb, BenBen (at Rainbow Bridge), Jane, Willow, Lilly, and the recent foster failure Rosie
2014 Palazzo 33.2
kokosfriend is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-29-2008, 08:27 AM   #2
Senior Member
 
Join Date: Sep 2001
Posts: 219
Used it at one campground and the next time I hooked up it wouldn't work. It has propane to the regulator as it hiss/pops when taking the hose off. When I hook the regulator onto the grill and open the burner to lite, I get a quick burst of propane (hiss) and then nothing more. Something seems to sop it. I run it off of the motorhome tank, but like I said, there is propane in the line. The other appliance (stove) runs OK. I have turned the propane tank off and then slowly back on, but still nothing. Anything else I can try???
__________________

__________________
Barb, BenBen (at Rainbow Bridge), Jane, Willow, Lilly, and the recent foster failure Rosie
2014 Palazzo 33.2
kokosfriend is offline   Reply With Quote
Old 10-29-2008, 09:40 AM   #3
Senior Member
 
GaryKD's Avatar
 
Newmar Owners Club
Join Date: Jul 2006
Location: Wellington, Florida
Posts: 12,315
It sounds like the grill is asking for more propane than the saftey gizmos will provide. Consider trying a portable bottle of propane (the small ones that screw into the grill). If it runs okay from the small portable bottle then you'll need to determine how to match the grill with the coach delivery system. The length of the hose run could contribute to this problem. I use the coach tank run a portable grill. I had a very long hose attached to the extend a stay adapter. I needed to shorten the length of the hose and everything works okay.
__________________
Gary
2005 Newmar KSDP 3910 + GMC ENVOY XUV 37K lbs Moving Down The Road
The Avatar Is Many Times Around The USA
Nobody Knows Your Coach Like Somebody Who Owns One Just Like Yours
GaryKD is offline   Reply With Quote
Old 10-29-2008, 10:22 AM   #4
Senior Member
 
Join Date: Sep 2001
Posts: 219
I have been using this grill on the motorhome tank for about 4 years. This is the first time I have had this happen
__________________
Barb, BenBen (at Rainbow Bridge), Jane, Willow, Lilly, and the recent foster failure Rosie
2014 Palazzo 33.2
kokosfriend is offline   Reply With Quote
Old 10-29-2008, 01:45 PM   #5
Senior Member
 
Max Hubrich's Avatar


 
Workhorse Chassis Owner
Join Date: Mar 2007
Location: Pikeville, NC
Posts: 1,724
I had a similiar deal last year-- It was the propane hose. Got a new one and no more problems.
__________________
Max H,
2002 Newmar Mountain Aire, 37', 3778, W-22, 8.1 Vortac, Ultra Power upgrade, CAI (cold air intake), Taylor wires, colder plugs, Koni shocks.
Max Hubrich is offline   Reply With Quote
Old 10-29-2008, 04:07 PM   #6
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
Make sure the regulator is fully seated on the hose and the hose is fully seated into the valve on the motorhome. I run the same grill off the Extend-A-Stay Deluxe and 2 12' hoses with no problem.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 10-30-2008, 03:33 AM   #7
paz
Senior Member
 
paz's Avatar
 
Join Date: May 2005
Location: Full-timers - Home is where we park it.
Posts: 4,716
I had the same thing happen once. I think our propane tank had recently been filled, and with the grill sitting lower than the tank, apparently some liquid propane got into the hose. If your regulator hisses and pops, that may be what happened to you, too. The hissing and popping is the propane evaporating. I removed the hose, allowed it to sit and warm up, and it hasn't happened since.
__________________

__________________
2015 DRV Tradition 375KPS
2015 Chevy Duramax 3500HD LTZ Dually
Full-timers...Home is where we park it.
Check out our blog: Living Our Dream
paz is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Winegard roadtrip HdDirectv conversion soarsz Tiffin Motorhomes Owners Forum 1 03-30-2008 04:42 AM
I need a new grill D and J Excel Owner's Forum 4 09-06-2007 08:28 AM
Winegard 12 " RoadTrip Satellite Edmund A Skibinski iRV2.com General Discussion 4 09-14-2006 03:40 AM
Windgard 12" RoadTrip Satellite Edmund A Skibinski Newmar Owner's Forum 1 09-12-2006 12:19 PM
BBQ Grill RayRiviere Travel Trailer Discussion 21 03-10-2006 04:31 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.