Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-02-2011, 10:54 AM   #1
Junior Member
 
Join Date: Oct 2011
Posts: 23
Concerned!! 50 Amp Panel Clicking

Fellow RVer's,

This forum has provided many answers to my RV questions and I turn to your expertise once again.

We have a 2004 Monaco Windsor. Recently we have begun to hear a periodic clicking inside the 50 amp distribution panel in the bedroom. No breakers have been tripping, I haven't noticed lights dimming or browning but the clicking is a bit unnerving. It isn't any of the breakers themselves clicking but somewhere in the panel.

We have a 2500 watt intellitec inverter with a Smart EMS Xantrex RC7 GS controller.

We are currently attached to 20 amp service up here in MA. We are running a small electric heater to supplement the coach heat but I have not seen the EMS exceed 20 amps on the digital read out.

We will be moving into an apartment shortly and will have the panel checked out by an RV center before putting the coach into storage. I want to reassure DW that the panel won't spontaneous light up and to be able to talk intelligently with the tech.

What is causing the clicking? Thanks for all your help.

Bill
__________________

__________________
mrbodywork is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-02-2011, 03:05 PM   #2
Senior Member
 
GaryKD's Avatar
 
Newmar Owners Club
Join Date: Jul 2006
Location: Wellington, Florida
Posts: 12,324
Hi mrbodywork,
Welcome to iRV2. Consider posting this question in the Monaco Owner's forum. On the iRV2 main page, scroll down to the Owner's Corner. There you will find a forum specifically for Monaco products. I suggest this because nobody knows your coach like somebody who owns one just like yours.

For me, I'd do nothing until you connect to 50 AMP shore power. 50 AMP shore power is really 100 AMPS available to the coach. 20 AMP power is just that, 20 AMPS. Regardless what the monitor says, operating your coach on a 20 AMP power source is a challenge for the EMS.
__________________

__________________
Gary
2005 Newmar KSDP 3910 + GMC ENVOY XUV 37K lbs Moving Down The Road
The Avatar Is Many Times Around The USA
Nobody Knows Your Coach Like Somebody Who Owns One Just Like Yours
GaryKD is offline   Reply With Quote
Old 12-02-2011, 03:15 PM   #3
Senior Member
 
Tallyrver's Avatar


 
Heartland RV Club
Join Date: Mar 2010
Posts: 695
Welcome to the forum...On my 07 Neptune I had the same clicking ,a tech at Lazy days said it was the EMS unit shedding power . There are relays inside the panel . I had an inverter that had issues and the EMS was trying to compensate for it.

Wayne
__________________
Wayne and Debbie
2014 Gateway 3650BH
2008 F350 dually diesel .
www.mudflapscampingclub.com
Tallyrver is offline   Reply With Quote
Old 12-02-2011, 03:38 PM   #4
Senior Member
 
wa8yxm's Avatar
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 22,825
You told us about your inverter.. You did not tell us the make of the panel that's clicking nor did you mention if you have an EMS unit and it's model.

I can think of several reasons for clicking behind the panel.. alas, I need the answers to the above to figure it out.
__________________
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 12-02-2011, 07:40 PM   #5
Senior Member
 
Join Date: Jan 2004
Location: Canyon, TX
Posts: 489
Plus--A picture is worth a thousand words.

If you could download a picture of the unit that is "clicking" it would be a big help!
__________________
Traveling America In
"God's Grace"
MikeandClaudia is offline   Reply With Quote
Old 12-03-2011, 09:49 AM   #6
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 18,096
It's the EMS shedding power. The EMS is built into the 50A load center and is trying to manage you down to 20A when you have that heater running. The heater is probably drawing 13-14 amps all by itself, so there isn't much left for anything else. The click is the EMS opening a circuit to hold the amps to 20. Then it reconnects the power and quickly sees that it is still going to exceed, 20A, so it opens the circuit again. In other words, it is doing what it is supposed to.

Trying to run an electric heater with only 20A available is problematic at best. Shut if off and use the propane furnace instead. That way you will have some electric left for the rest of the coach.
__________________

__________________
Gary Brinck
Former owner of 2004 American Tradition
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Panel TV Project Started TQ60 iRV2.com General Discussion 12 01-24-2013 08:38 PM
Clicking Intellitec EMS-No Shore Power crah Monaco Owner's Forum 7 10-16-2011 11:29 AM
50 amp service hassels. TEDDE Monaco Owner's Forum 29 05-24-2011 04:06 PM
50 amp power down to 15 amp power TEDDE Monaco Owner's Forum 29 05-04-2011 11:08 PM
30 to 50 amp conversion Mikep186 MH-General Discussions & Problems 6 03-24-2011 09:37 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:48 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.