Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 09-11-2011, 10:18 AM   #1
Junior Member
benningtonr's Avatar
Join Date: Aug 2011
Posts: 10
Couple Problems, any advice would be appreciated

Problem 1:
the Onan 7Kw genset, when I got the MH, it ran for 16-20 mins (timed)
i disconnected the fuel line from the fuel pump to the fuel tank and replaced it with a longer hose and ran it into a gas can.
when cranking the gen over it would not start and bubbles would appear in the fuel jug, not a lot mind you but enough.
I wiped the hose and held it to my tongue to see if i could feel any suction, none was discernible.
so I figured I would get an electronic fuel pump from the parts store and place it in line, in place of the oem pump.
The unit would now stumble and only run if I manually worked the throttle linkagae, but die as soon as the button was released. I hooked a meter to the fuel pump and voltage was removed as soon as the start button was released.
I then noticed that there was a solenoid on the side of the oem fuel pump, figuring that it sensed pressure i ran the new pump in series with the oem.
same results. I now have the genset back to oem condition, and i can no longer get it to start, even moving the throttle linkage does not help. So i have made it worse, used to run then die after 16-20 min, now i cannot get it started.

Problem 2:
I have an hwh leveling system, it powers up, pressing the I button a second time is supposed to drop the jacks, but instead I get the battery indicator lighting up, i have tried it in the ACC position and while the coach is running. same results.

I have a trip to the IHRA Bracket finals in Rockingham, NC at the end of the month and would really like to get these issues solved,

Thank you again for your time and any assistance you may be able to provide.

benningtonr is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-11-2011, 10:26 AM   #2
Senior Member
Mr JP's Avatar
Newmar Owners Club
Join Date: Dec 2009
Posts: 360
You should be able to get a blinking code from the start switch. It is a two part code & that will help trouble shoot. Here is a link to a manual http://www.cumminsonan.com/www/html/...s/983-0101.pdf

Good Luck JP

Just the Wife & Me and the Two Dogs!!
2011 Newmar Mountain Aire 4344 !!
450HP Cummins on a Freightliner Chassis !!
Mr JP is online now   Reply With Quote
Old 09-11-2011, 11:16 AM   #3
Senior Member
Skip426's Avatar

Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 11,963
Benningtonr, could you re-post with more info if possible. Year and model of coach and leveling system, gas or diesel . I just had to replace the main 40 amp fuse on my HWH due to corrosion in the fuse holder. Fuse was in line about 8" from the pump motor and is the main feed for the whole system.
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 09-11-2011, 01:39 PM   #4
Senior Member
Cougarkid's Avatar
Freightliner Owners Club
Overland Owners Club
Join Date: Sep 2011
Location: Mid-Missouri
Posts: 599
How much fuel is in the tank?
Most MH's have a fail-safe cut-off if the fuel tank is under 1/4 full. Keeps you from running out of gas sitting still with the generator running.
Mike and Carla
1998 42' Overland Larado Diesel Pusher
On the road - here and there - Full Timing
Cougarkid is offline   Reply With Quote
Old 09-11-2011, 07:22 PM   #5
Senior Member
Join Date: Jul 2011
Posts: 918
Do you have the parking brake on? On my coach, if the auto park brake on the dash is not engaged, the HWH levelers will not deploy. Also, your 12v house power switch must be "on".
2004 Tiffin Allegro 27.5 ft. P32 18,000 lb GVW. 8.1 liter. Workhorse chassis built May 2002. 21,000 miles. 2012 Jeep Liberty Toad. RVi2 brake unit.
Full.Monte is offline   Reply With Quote
Old 09-12-2011, 12:07 AM   #6
Senior Member
Skip426's Avatar

Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 11,963
A little more to check out. If you coach is wired up for the levelers the same as mine, the HWH system takes it's operational power from the coach batteries, and a signal power feed from the Acc, side of the ignition switch. So the levelers will only power up with the engine off, ignition switch in Acc . If your getting a low batt warning, bad coach batteries or a poor connection, between the batteries and the pump/ control box is also a possibility.Even a bad ground at the batteries is a possibility.Gen set starting power is also from coach batteries, could be a common issue for both your problems.
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 09-12-2011, 08:50 AM   #7
Junior Member
benningtonr's Avatar
Join Date: Aug 2011
Posts: 10
Jacks are fixed, it was a contact problem on the batteries, I loosened the cables and retightened, it works like a champ now.

I have a 1992 Oshkosh chassis ford gas engine.
gen is a 7 NHM F A 26106 C
benningtonr is offline   Reply With Quote
Old 09-12-2011, 10:24 AM   #8
Senior Member
Dave78Chief's Avatar
Join Date: Jun 2009
Posts: 1,504
The Onan Service manual for a "7 NHM F A 26106 C" is 965-0531B (http://www.cumminsonan.com/www/pdf/m.../965-0531B.pdf). You have a Spec C unit. You have to be real careful when using that manual as it covers several different versions. As such it can be confusing if you do not pay attention to the details. Translation: It will refer to things that may not be on your model (Spec #).
You do not have a computerized unit that provides fault codes.
The wiring diagram for yours is on page b-3.
You have the Electronic Governer control system version (page 7-8).
Spec C would not have the K4 fuel pump relay.
Troubleshooting (for your symptoms) starts on Page 7-16 & 17.
Sit down and read the Control section (7), the Ignition portion in Section 6, and the A-4 through A-6 troubleshooting protions. They all interract with each other.
Fuel pump pressure (page 6-29) is only 3.5-6PSI. Make sure you have > 1/4 tank of gas in the tank (prevents you from running tank dry so you can get to gas station). Clogged fuel filter can easily create problems.


Dave in Virginia
1978 Winnebago Chieftain
Dodge M400 - 440-3
Classic Winnebago Site: http://www.classicwinnebagos.com/forum/index.php
Dave78Chief is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
First trip, couple of problems sqzdog Winnebago Industries Owner's Forum 9 08-10-2011 01:20 PM
New to everything, looking for advice! Melrose Expandables, Hybrids, & Lightweights Discussion 17 05-01-2011 08:55 PM
Couple of problems solved TidTrakr iRV2.com General Discussion 0 09-28-2010 08:51 AM
Advice about Purchasing a 2003 Aerolite Cub C-236? jenbhansen Travel Trailer Discussion 0 06-14-2009 04:56 AM
Brake Problems lera Alpine Coach Owner's Forum 4 04-05-2009 12:07 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:14 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.