Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 04-12-2012, 12:06 PM   #15
Junior Member
Join Date: Jan 2012
Posts: 8
allison shifter

Just to finish this I went to Williams in Phoenix with my control unit in hand. I had been getting NN's for 10 seconds but would not stay. When I walked in I assumed they may be able to reprogram or maybe worst case scenario, a new control unit, my estimate maybe $1500.

After a couple hours waiting they told me (after I went to the desk and asked, I was 30 ft away in the waiting room) that my unit showed no light and I needed a new one. $2800 later I walked out the door in total shock.

I did get a one year warranty. Seems like a lot of money for 2 circuit boards and a computer chip with proprietary code.

My error for not checking for another source. Still don't know why I could get NN for 10 seconds and them nothing.

Thanks to all that responded. I did improve power to ECU by changing the splice behind the battery.

tzummy is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP, She Won't Start sgtjoe National RV Owner's Forum 10 07-09-2011 09:04 PM
1988 Chevy C30 based RV w/5.7 & EFI that will not turnover and start DougCP Class C Motorhome Discussions 8 07-07-2011 08:20 PM
Volt gauge reading at start up for Dutch Aire clubmed98 Newmar Owner's Forum 7 05-26-2011 06:23 PM
A/C Hard Start Kit RJay RV Systems & Appliances 5 04-30-2011 10:29 PM
Onan 7.5 Diesel Genset generator will not start yelvero MH-General Discussions & Problems 20 03-20-2011 06:11 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:40 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.