Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 12-12-2010, 02:12 PM   #1
Junior Member
Newmar Owners Club
Join Date: Nov 2010
Posts: 15
Cummins low water alarm

Newbie here! just purchased a 03 MA with a Cummins ISL 400, Freightliner Chassis. When starting the unit from being cold, Illinois weather, I am getting a low water alarm that is going off. Checked the white tank that is right in front of you when you open the hood. Antifreeze was at the low mark, added to it to the half way mark to maximum level. After the rig idles for about five minutes the alarm goes off. I noticed two caps on this tank, one being a standard radiator cap the other being a large black cap that fills your hand when grabbing it. Can the system be that low? When in the coach, you can hear what sound like water running through a pipe as you static rev the motor. I assume that is water being supplied to the heat exchanger under the dash. Any thoughs? Walt Thanks

waltmack is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-12-2010, 02:18 PM   #2
Senior Member
GaryKD's Avatar
Newmar Owners Club
Join Date: Jul 2006
Location: Wellington, Florida
Posts: 11,772
Hi waltmack,
My Cummins and Spartan setup has the low coolant measurement sensor in the expansion tank. If you find the low coolant sensor then you'll know where the measurement is taken from. The sensor may have two or more wires coming from it. Keep coolant covering this sensor and the alarm should remain silent.

2005 Newmar KSDP 3910 + GMC ENVOY XUV 37K lbs Moving Down The Road
The Avatar Is Many Times Around The USA
Nobody Knows Your Coach Like Somebody Who Owns One Just Like Yours
GaryKD is offline   Reply With Quote
Old 12-12-2010, 03:02 PM   #3
Moderator Emeritus
Mike Canter's Avatar

Join Date: Apr 2008
Location: Freeport, ME
Posts: 4,700
Normally if you can hear water rushing means you are low on coolant. After you filled the tank the the level go back down after it ran for a short time and the alarm went off again. If it did then you need to start adding a 50/50 mixture of antifreeze and distilled water. This is not the antifreeze used in a car but special antfreeze for diesel motors. If the antifreeze is green then that means most of the time it is not the newer lifetime OAT stuff but again you need the diesel antifreeze.
Mike Canter
"Gunner" USN Retired, Airdale
2004 Monaco Signature 44' Conquest. Detroit 60
Mike Canter is offline   Reply With Quote
Old 12-14-2010, 12:01 AM   #4
Junior Member
Newmar Owners Club
Join Date: Nov 2010
Posts: 15
Hey! thanks for the info, topped everything off, still singing tho. Bad sensor. Changed out, everything quite now.
waltmack is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cummins 330 low idle will pulse on occassion dobrien Class A Motorhome Discussions 4 06-26-2008 01:17 AM
Cold Water - Low Pressure Stargazer49 RV Systems & Appliances 4 08-26-2007 02:37 PM
Low Voltage Alarm BobD Workhorse and Chevrolet Chassis Motorhome Forum 2 07-02-2006 12:23 PM
water pressure is low Our Cow MH-General Discussions & Problems 6 03-25-2006 04:31 PM
Low Fuel Alarm Suncruiser Ron Workhorse and Chevrolet Chassis Motorhome Forum 11 03-21-2006 04:27 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:15 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.