Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-23-2011, 01:14 PM   #1
Member
 
olly72's Avatar
 
Join Date: Jan 2008
Posts: 68
dash ac

Hi All: Ihave a 2007 ford chasis itasca 32 foot sunrise. The ac just quit working. It blows the air but itisn't cool. I'm thinking it should be a fuse. Lookingat themanual I can't find the right one. Any suggestions would be appreciated.
Russ
__________________

__________________
olly72 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-23-2011, 01:37 PM   #2
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 4,383
the # 1 cause would be low freon. You have a low pressure switch that cuts off the pump when low on freon. I would start there.
__________________

__________________
1998 Pace Arrow 35 ft. F53 Ford V10 2012 Honda Civic toad
32 years mechanic at Delta Air Lines 15 year motorhome service manager. 3 popups....2 travel trailers....5 motorhomes....loved them all.
ga traveler is offline   Reply With Quote
Old 09-23-2011, 10:25 PM   #3
Senior Member
 
sc3283's Avatar
 
Join Date: Aug 2011
Posts: 1,126
Not cooling could be many things...from any sort of electrical problem to low/no freon to warm air door open in the evap box. With engine running turn on the dash AC and see if compressor clutch is engaged and spinning. If so....then the electrical portion is fine. Next would be to check pressures and go from there.
__________________
sc3283 is offline   Reply With Quote
Reply

Tags
dash



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash cluster acting very strange dcoff12 Workhorse and Chevrolet Chassis Motorhome Forum 6 02-23-2011 09:05 PM
Dash Display Woes roger1938 Workhorse and Chevrolet Chassis Motorhome Forum 23 12-11-2010 01:17 PM
Anyone change the tv location from below the dash to above the dash??? Born2RV MH-General Discussions & Problems 11 03-14-2010 03:53 PM
2000 Winnebago 35U Squeaky Dash David Kanoy Winnebago Industries Owner's Forum 7 04-03-2009 06:16 AM
Dash A/C Repair - Need some sage advice chasfm11 MH-General Discussions & Problems 11 11-06-2005 02:18 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:19 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.