Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-24-2014, 05:57 PM   #1
Member
 
Winnebago Owners Club
Join Date: May 2014
Posts: 59
Dash gauges do not work

I have a Winnebago 2001 Journey DL. The air gauges were erratic so I repaired the VDC and all worked well. The horn stopped working so I got out the o' wiring diagrams and began searching. I traced the wire down the steering colum beneath the floor to the underside where I found a broken wire. I repaired the wire and the horn worked perfectly. I started the engine to see that the air horn worked--it did. But I noticed than none of the gauges were registering. The lights all came on, did their work and went out, but the gauges will not register. I called Freightliner tech support and explained this to him and the tech said it sounded like the VDC unit went bad. He also sent some wiring diagrams--but they are for a truck, and they really didn't help much. I finally purchased a new VDC unit, expensive!; installed it; and no gauges. The dash lights still function, but not the fuel, heat, air, or gen gauges. The tach does work. I've not driven it since installing the VDC, so I'm not sure of the speedometer. I've checked fuses, cleaned the plugins, checked the 135 amperes, traced the wiring, but nothing. So I donít think the problem is the VDC; it seems more like some kind of wiring problem. Any suggestions. Does anyone have a wiring diagram for the VDC?
__________________

__________________
wilson8ford is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-25-2014, 04:06 AM   #2
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
Check and insure you have a good ground conductor for the dash; adding an extra is the easiest way. What kind of testing meters or probes do you have available?
__________________

__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 08-25-2014, 04:39 AM   #3
Member
 
Winnebago Owners Club
Join Date: May 2014
Posts: 59
Thanks. I've checked the ground, according to the wiring diagram it's the black wire. I traced it all the way to the ground stud where a couple of blackground wires collect. I'm using an ohm meter to check the ground. The dash instrument lights all work properly. When the key is turned on, they all light up, go thrugh the check up and turn off. Even the air pressure light stays on until pressure is reached and then shuts off. That is why I was hesitant about purchasing a new VDC, but went ahead and did it. With the new unit, everything acts as it did before. I'd like to get a wiring diagram for this unit; the one Freightlinere sent is for a truck and doesn't seem to fit right. I'd especially like to get a wiring diagram for the VDC. I understand there's a ground and two 12v wires to that unit and I'd like to check it. Thanks for puzzling about this issue.
__________________
wilson8ford is offline   Reply With Quote
Old 08-25-2014, 08:44 AM   #4
AGP
Senior Member
 
AGP's Avatar
 
Monaco Owners Club
Join Date: Jul 2011
Location: Palm Coast Florida
Posts: 236
I purchased a new Journey in 2001,had the same problem. I had the coach for 4 years and lost the dash gauges on three separate occasions. There was a connection problem in the harness under the motorhome about half way down the coach towards the rear. Freightliner repaired it each time.
__________________
Tony, Nancy & Abby the pooch 2011 40'Monaco Knight PDQ Maxxforce 10 Jeep Wrangler Unlimited
AGP is offline   Reply With Quote
Old 08-25-2014, 12:57 PM   #5
Member
 
Winnebago Owners Club
Join Date: May 2014
Posts: 59
Thanks

Hi Tony and company,

I know it's a long way off--time wise--but it doesn't hurt to ask: Would have any records of information about what Freightliner did?
__________________
wilson8ford is offline   Reply With Quote
Old 08-25-2014, 01:08 PM   #6
Senior Member
 
terry735001's Avatar
 
Join Date: Sep 2012
Posts: 1,158
Blog Entries: 11
i think your dash gets alot of info on a cam bus side it only takes 1 wire for all this to be lost

giving what you say is working i feel it is that
__________________
terry735001 is offline   Reply With Quote
Old 08-25-2014, 03:01 PM   #7
Senior Member
 
rgvtexan's Avatar
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Oct 2009
Location: NE WA or S TX
Posts: 2,232
This Service Bulletin may be of help. It has trouble shooting and wiring info.
Enjoy!
Attached Files
File Type: pdf System III.pdf (127.9 KB, 151 views)
__________________
04 Horizon QD, 12 Ford Flex, Excalibar, Brakemaster, Winter Texan, RVin! since 1974
Norm, Donna & Tinker Kat 74 MGB-GT, 75 MGB, 01 Z3
Life is a Timed Event, you only get One Go Around!
rgvtexan is offline   Reply With Quote
Old 08-25-2014, 04:52 PM   #8
Member
 
Winnebago Owners Club
Join Date: May 2014
Posts: 59
Thanks for the service bulletin. I've been in touch with Freightliner customer service and the tech made a suggention that I'll try. May with that and the wiring info on the survice bulletin, I can make some progress. More later.
__________________
wilson8ford is offline   Reply With Quote
Old 08-25-2014, 07:49 PM   #9
Member
 
Winnebago Owners Club
Join Date: May 2014
Posts: 59
More on the gauges: Norm sent me servicer bulletin 54-12 and that was very helpful. Using that data I determined that each outlet on the wiring harness had the correct voltage. The ground checked good, but just to eliminate that possibility, I ran a direct ground from the black ground wire to the frame—the results were the same. All the message center (MC) lights function correctly. I’ve been in touch with a tech person, John, from the Freightliner customer service and we tried several tests—plugging in the outlets to different gauges to see if I could find one that works, checking the ground, again, etc. He thinks that I must have had a 12 volt surge and ruined the gauges. The VDC seems to be working properly and sending the voltages to the gauges. I guess my next step is to either purchase a gauge or contact the local Freightliner dealer and see if they have a way to check the gauges or have a test gauge they can plug in to see if it works. Oh well, it’s only money; it ain’t worth having if one can’t send it.
__________________
wilson8ford is offline   Reply With Quote
Old 08-25-2014, 10:20 PM   #10
Senior Member
 
terry735001's Avatar
 
Join Date: Sep 2012
Posts: 1,158
Blog Entries: 11
did you have time to look at the instr data bus + and - wires

i am looking at your wiring dy now

all so J1587 + and - on your data bus going in to your VDC could be open as well ... i am sure this is wiring you may have not look at yet as it gos back to the motor

+ and - are not 12vdc just saying it that way as they are in wiring dy

the set of wires are like a computer com port and thats how the system talks
if one of the wires is open any where from the 40 feet back to the ECM or to the dash then its not going to work

but there is one thing that dos stand out you say the fuel, heat, air, or alt gauges do not work and they are coming in on there own wires

if it was info from the ECM not making it it would be oil PIS and more

but i am still with you i think when fixing the wire from befor a pin may have been pulled out of a plug some where
__________________
terry735001 is offline   Reply With Quote
Old 08-25-2014, 11:49 PM   #11
Member
 
klcracing's Avatar
 
Join Date: Jul 2014
Location: Lawton, Ok
Posts: 41
I have an 07 FW Expedition w/Freightliner chassis and had a problem with intermintent air gauge. It ended up being the wiring harnesses behind the VDC that connect all the gauges together, I believe 6 wires. Hope this is helpful, but you sound way beyond that, however the simple is often overlooked. Good Luck !
__________________
klcracing is offline   Reply With Quote
Old 08-26-2014, 07:10 AM   #12
Member
 
Winnebago Owners Club
Join Date: May 2014
Posts: 59
Thanks. Terry, I'll look farther into the connections you mentioned. With the service bulletin
Norm sent it will be easier to track these circuits down. I was ready to stop with the gauges, but now I’ll look deeper. As I mentioned earlier, the plugs for all the gauges have the correct voltage reading according to the service bulletin and the information the Freightliner rep, John, gave me. Since all the MC lights function properly and the voltage to the plugs is correct, does this seem to be an indication that the VDC is working properly. If it wasn’t, it seems that there would be no, or at least incorrect, output to the gauge plugs. Thanks for your help and suggestions. I just spent big $$$ on the VDC, so I’m not anxious to begin throwing $$$ at the gauges if it’s not necessary. I’m going to chase down all these suggestions before I do. Again, thanks to all.
__________________
wilson8ford is offline   Reply With Quote
Old 08-26-2014, 07:28 AM   #13
AGP
Senior Member
 
AGP's Avatar
 
Monaco Owners Club
Join Date: Jul 2011
Location: Palm Coast Florida
Posts: 236
Quote:
Originally Posted by wilson8ford View Post
Hi Tony and company,

I know it's a long way off--time wise--but it doesn't hurt to ask: Would have any records of information about what Freightliner did?
Any records I had were traded in with the rig. Just my fading memory remains.
__________________
Tony, Nancy & Abby the pooch 2011 40'Monaco Knight PDQ Maxxforce 10 Jeep Wrangler Unlimited
AGP is offline   Reply With Quote
Old 08-26-2014, 11:02 PM   #14
Senior Member
 
Join Date: Nov 2003
Location: Richmond Hill, GA USA
Posts: 671
From SB 54-12

If data is not received from the VDC for more than 45 seconds, the icon lights will "dance" or initiate a chase pattern, indicating no reception of data. Data is sent from the VDC to the MC and on to the instruments.


Since you're not seeing the chase pattern on the message center, I think this means that you're getting data to the message center.

Looking at the diagram and remembering what you've already verified, my guess is the data circuit from the message center to the guages is bad.

Is there a connector on the message center for the 7 volts, ground, and data (3 wires) going to the guages? If there is, try examining it for a loose pin and then reseat it. (I'm guessing here as I've never had to look at mine.).

Please let us know when you finally solve the mystery.

Fred
__________________

__________________
Fred & Vicki
St. Augustine, Fl.
Fred Cooper is offline   Reply With Quote
Reply

Tags
dash, gauges



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Motorhome Dash Covers...finally! Navimama iRV2.com General Discussion 52 07-19-2014 11:29 AM
Dash cover information request RTegarini Winnebago Industries Owner's Forum 7 03-29-2014 09:21 PM
2001 Itasca Suncruiser Dash Switch Degabound Winnebago Industries Owner's Forum 2 02-15-2014 07:40 PM
04 tradition dash gauges going crazy ted sparkes Fleetwood Products Owner's Forum 1 12-19-2013 08:05 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:24 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.