RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-16-2017, 11:46 AM   #1
Member
 
tombottcat's Avatar
 
Join Date: Feb 2014
Location: Airdrie Alberta Canada
Posts: 87
DASH issues

2016 TUSCANY XTE have a strobe light happening at night on the dash instrument cluster, seams to happen a lot,phone freightliner and they said they were aware of the problem?great response for a guy that has to throw a towel over his dash to drive?also the odometer with 16,000 miles just zeroed to 107? made call to Freightliner again- same response ? funny when things go south no one seems to no anything. spoke to Thor and its Freightliner-Freightliner is a dash issue. should get my guitar out and make a darn song! TOM AND JOANNE - - DAY DRIVERS ONLY
__________________

tombottcat is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-16-2017, 12:02 PM   #2
Senior Member
 
Pelledan's Avatar
 
Join Date: Sep 2010
Posts: 351
I'll be interested in the odometer fix. I recently had a similar event happen to be on my way back from a trip to the UP. My odometer went from 58xxx miles to 1607 miles in the snap of a finger. Went in for service and they (Freightliner) found a bad cable connection from the ECM to some other gadget and repaired it. However, they told me that they could not reset the odometer to it's correct mileage display (the correct mileage is always held in the ECM) because that would constitute tampering. I even called corporate Freighliner and was told the same thing. So now every time I need the correct mileage I need to enter the ECM through my info center. What a PITA!

Dan
__________________

__________________
2006 Winnebago Journey 36GSE; 2014 CRV; Blue Ox; SMI AF-1
Pelledan is offline   Reply With Quote
Old 04-16-2017, 12:05 PM   #3
Member
 
tombottcat's Avatar
 
Join Date: Feb 2014
Location: Airdrie Alberta Canada
Posts: 87
Interesting, thank you for the info, will talk to my service centre on Monday

Sent from my HTC One_M8 using iRV2 - RV Forum mobile app
tombottcat is offline   Reply With Quote
Old 04-16-2017, 12:53 PM   #4
Junior Member
 
Join Date: Apr 2017
Posts: 29
What does Freightliner do with the over the road truckers when that happens? Seems like a major problem for them...
DWJoyce is offline   Reply With Quote
Old 04-16-2017, 01:24 PM   #5
"Formerly Diplomat Don"
 
Dutch Star Don's Avatar
 
Newmar Owners Club
Join Date: Apr 2005
Location: Moorpark, Ca.
Posts: 12,749
I believe Freightliner has a recall for this dash issue. Mine started acting funny on a recent trip, gauges reading weird. I called Freightliner and they said they've had issues, but mine didn't fall within the recall parameters....great.

I was told to unplug the two plugs at the rear of the dash and reconnect. I did that and the problem was solved. The same issue arose about 300 miles later, so I did it again and left the dash screws out. We were on a 7K trip and I wouldn't be seeing a dealer until we got home. It never happened again. Try the disconnect procedure. The dash cluster should only have 5 screws.
__________________
Don & Mary
2019 Newmar Dutch Star 4018
2016 GMC Canyon 4WD Crew Cab
Dutch Star Don is offline   Reply With Quote
Old 04-16-2017, 01:59 PM   #6
Member
 
tombottcat's Avatar
 
Join Date: Feb 2014
Location: Airdrie Alberta Canada
Posts: 87
Thanks Don, appreciate the info and will try that, kinda like a computer

Sent from my HTC One_M8 using iRV2 - RV Forum mobile app
__________________

tombottcat is offline   Reply With Quote
Reply

Tags
dash



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash a/c issues Bill54 Monaco Owner's Forum 4 06-17-2013 07:31 PM
Dash speaker issues Tomp4801 Newmar Owner's Forum 3 01-22-2013 05:57 PM
2000 Beaver Monterey Dash Radio Issues sleonewa Monaco Owner's Forum 3 09-05-2010 11:20 AM
Dash air issues!! softballdad25 Workhorse and Chevrolet Chassis Motorhome Forum 32 09-12-2007 11:21 AM
Dash air issues!! softballdad25 Winnebago Industries Owner's Forum 8 08-15-2007 02:43 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:19 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.