Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-13-2011, 02:45 PM   #1
Senior Member
 
Lincolnboy2's Avatar


 
Texas Boomers Club
Fleetwood Owners Club
Solo Rvers Club
Ford Super Duty Owner
Join Date: Jul 2011
Location: Grand Prairie, TX (DFW)
Posts: 3,536
Dash receptacle/cigarette lighter not working

2003 Fleetwood Storm, cant get my cell phone charger to come on when I plug it in to the dash receptacle. Tried moving it, re plugging it around different spots, etc. No luck. Doesnt matter whether the ignition is on or off. Ideas?

Thanks!
__________________

__________________
Lincolnboy2 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-13-2011, 03:16 PM   #2
Senior Member
 
Triker56's Avatar
 
Fleetwood Owners Club
Join Date: Jun 2009
Posts: 3,950
Check for power at the receptacle.
If no power there look for a blown fuse.

If you have power at the receptacle.
Check the fuse in the cell phone charger.
__________________

__________________
99 Discovery 34Q ISB
2014 MKS AWD EcoBoost Toad
Fulltime Since "99"
Triker56 is offline   Reply With Quote
Old 07-13-2011, 08:56 PM   #3
Member
 
wingman8's Avatar
 
Join Date: May 2011
Location: ottawa ks
Posts: 68
Question

Mine does not work unless the house batteries are on. Try that
__________________
wingman8 is offline   Reply With Quote
Old 07-14-2011, 06:26 AM   #4
Senior Member
 
Lincolnboy2's Avatar


 
Texas Boomers Club
Fleetwood Owners Club
Solo Rvers Club
Ford Super Duty Owner
Join Date: Jul 2011
Location: Grand Prairie, TX (DFW)
Posts: 3,536
Thanks! I'll do just that! Appreciate the help.!
__________________
Lincolnboy2 is offline   Reply With Quote
Old 07-14-2011, 12:56 PM   #5
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 4,383
On my Fleetwood Pace Arrow, My dash lighter plug is always hot. No matter wheather the disconnect is on or off. I think the fuse is in the panel under the hood. Right in front of the driver. You can also check that the wire is not loose on the back of the plug.
__________________
1998 Pace Arrow 35 ft. F53 Ford V10 2012 Honda Civic toad
32 years mechanic at Delta Air Lines 15 year motorhome service manager. 3 popups....2 travel trailers....5 motorhomes....loved them all.
ga traveler is offline   Reply With Quote
Old 07-15-2011, 01:41 PM   #6
Senior Member
 
Lincolnboy2's Avatar


 
Texas Boomers Club
Fleetwood Owners Club
Solo Rvers Club
Ford Super Duty Owner
Join Date: Jul 2011
Location: Grand Prairie, TX (DFW)
Posts: 3,536
thanks folks.
__________________
Lincolnboy2 is offline   Reply With Quote
Old 07-16-2011, 02:41 PM   #7
Member
 
wingman8's Avatar
 
Join Date: May 2011
Location: ottawa ks
Posts: 68
Did you find out what the problem was?
__________________

__________________
wingman8 is offline   Reply With Quote
Reply

Tags
dash



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash Display Woes roger1938 Workhorse and Chevrolet Chassis Motorhome Forum 23 12-11-2010 01:17 PM
2005 Dash AC fan is not working scottma Freightliner Motorhome Chassis Forum 5 07-12-2009 11:20 AM
Dash A/C Fan not working scottma Winnebago Industries Owner's Forum 6 06-28-2009 07:50 PM
Only high speed working on my dash blower Ken & Joyce Winnebago Industries Owner's Forum 9 01-14-2007 04:37 PM
Dash air stopped working? Donna & Chuck Alpine Coach Owner's Forum 8 06-26-2006 06:24 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.