Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-11-2014, 11:33 PM   #1
Junior Member
 
Join Date: Aug 2014
Posts: 4
Angry Defroster doesn't blow air on windshield

have a 2002 holiday rambler endeavor diesel 38ft motorhome. the dash a/c unit seems to work ok on all other levels but when turned to defrost mode, little or no air is blown towards the windshield. air still blows from lower vent near the floor. any suggestions?
__________________

__________________
ernie65 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-11-2014, 11:50 PM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,970

If you could have a look around under the hood and near the heater hoses look for the A/C unit manufacturers name; Evans & Denso are common.
The problem may come down to a leaking vacuum line to the air flow control servo for defrost.
One manufacturer uses vacuum servos the other electronic , so you need to know which your dealing with.

http://www.evanstempcon.com/serviceparts.php

HVAC Systems | DENSO Heavy Duty
__________________

__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 08-12-2014, 11:00 AM   #3
Senior Member
 
wa8yxm's Avatar
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 22,787
Since on MOST automotive (Including Evans) HEVAC systems DEFROST is DEFAULT I have only 2 suggestions.

1 Find the vacuum or pressure motors that pull the levers that operate the air gates.. one may have a broken bracket or missing screw (Only seen that one time in a whole lot of years)

Air gate may be jammed and not moving (Saw that once too)

Hoses unhooked from defroster vents letting all that lovely warm dry air come out under the dash instead of over it (Most likely cause).
__________________
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 08-12-2014, 11:05 AM   #4
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,970
Quote:
Originally Posted by wa8yxm View Post
Since on MOST automotive (Including Evans) HEVAC systems DEFROST is DEFAULT I have only 2 suggestions.
).
Thanks wa8yxm; I forgot all about, defrost being the default , when I posted, that will narrow the possible causes.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Monaco Dynasty 42' - Air levelling question Globetrotter Monaco Owner's Forum 20 07-18-2014 05:00 PM
2014 Tour Air Brake Squeal -freightliner chassis deschrock Freightliner Motorhome Chassis Forum 0 06-20-2014 12:04 AM
Low Air presure - Park Brake iamduane Alpine Coach Owner's Forum 15 05-07-2014 05:49 PM
Found Cold Air Leakage jcrowder47 Tiffin Motorhomes Owners Forum 0 04-10-2014 09:16 PM
Air Horn works low Psi but not full psi? hkindle Spartan Motorhome Chassis Forum 4 01-21-2014 08:46 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:39 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.