Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-12-2016, 10:04 PM   #1
Junior Member
 
Join Date: Feb 2016
Posts: 4
Discovery 2010 wiper quit working

2010 Fleetwood discovery wipers not working. Had a power flux with the generator and the wipers stop working along with the light in the bed room. Replaced the switched in the bed room and that fixed the lights, replaced wiper switch but they still do not work. Anyone have a solution or idea.
Glen
__________________

__________________
hedoiicple is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-12-2016, 10:07 PM   #2
Senior Member
 
Fleetwood Owners Club
Spartan Chassis
Join Date: Mar 2011
Posts: 296
Quote:
Originally Posted by hedoiicple View Post
2010 Fleetwood discovery wipers not working. Had a power flux with the generator and the wipers stop working along with the light in the bed room. Replaced the switched in the bed room and that fixed the lights, replaced wiper switch but they still do not work. Anyone have a solution or idea.
Glen
Just curious, is it on a Spartan chassis?
__________________

__________________
Cbones is offline   Reply With Quote
Old 02-12-2016, 10:16 PM   #3
Junior Member
 
Join Date: Feb 2016
Posts: 4
Yes this is a Spartan Chassis
__________________
hedoiicple is offline   Reply With Quote
Old 02-13-2016, 06:33 AM   #4
Senior Member
 
Fleetwood Owners Club
Spartan Chassis
Join Date: Mar 2011
Posts: 296
Quote:
Originally Posted by hedoiicple View Post
Yes this is a Spartan Chassis
You are not going to be happy with what I am going to tell you. More than likely, you burned out the chassis computer. It is located on the driver's side firewall. It looks like a big heat sink that has 2 large connectors that are secured with an Allen key in the center. Even though you do not have the VIP steering wheel, and instead you have a separate wiper switch which is not supposed to run through the chassis computer, Fleetwood in their infinite wisdom erroneously taps into Spartan's wiring. You can get the wiring diagram from both Fleetwood and Spartan, and try to isolate the wiper switch from the computer like I did. It literally took me 2 days to figure out which wires were intertwined, because they are not supposed to be connected unless you had the VIP steering wheel. After doing all that, I found that in short order, the headlights and the dash fan went kablooey. I reluctantly ordered a new chassis computer from Spartan, to the tune of around $700. When I installed the new computer, all my troubles went away. It is unfortunate, but inevitable. Fleetwood is not supposed to tie into the Spartan computer, but I found several Fleetwood side items running on the chassis wiring. Trust me, you will pull your hair out on this. I spent a lot of time on this exact same issue. Good luck, and please report back with your results.
__________________
Cbones is offline   Reply With Quote
Old 02-13-2016, 04:38 PM   #5
Junior Member
 
Join Date: Feb 2016
Posts: 4
Thanks for the info, I will check that out. Also my seat heaters do not work. I stopped at a RV dealer coming back from Talladega last year and they ran a new hot wire to the switch and that got my wipers to work but the washer and intermittent wiper dose not work. I will try and run the wires down as you suggested.
__________________
hedoiicple is offline   Reply With Quote
Old 02-14-2016, 08:10 AM   #6
Moderator Emeritus
 
Bruce C's Avatar
 
Nor'easters Club
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Dec 2011
Location: NH
Posts: 5,099
In some cases the wiper motor controls both park function for your wipers and the intermittent function. I recently had to replace a wiper motor due to the intermittent cycle not working. All is fine now. The motor will work on normal low and high but not on the intermittent cycle, and sometimes will not park in the proper location. Good luck hope this helps.
__________________
Bruce & Nancy
FMCA F280542
2004 Bounder 35E
US Navy Vet.
Bruce C is offline   Reply With Quote
Old 02-14-2016, 11:51 AM   #7
Junior Member
 
Join Date: Feb 2016
Posts: 4
Bruce, I will check that out because mine will not park either. Was your washer affected also?
__________________
hedoiicple is offline   Reply With Quote
Old 02-14-2016, 12:11 PM   #8
Senior Member
 
Join Date: Jul 2014
Posts: 9,796
Wiper motors I'm familiar with, although not all, have two sources of power.

One is hot to the motor, at all times, and controls the park mode. It powers an internal switch that breaks the circuit, every time it goes to the parked position.

The other is from a dash switch, to supply constant power to the motor so it will travel past the park position.

If the constant feed power is missing, the wipers stop wherever you turn them off.

Hidaway wipers not included. They reverse the motor to park.

Just some trouble shooting info.
__________________
twinboat is online now   Reply With Quote
Old 02-14-2016, 12:23 PM   #9
Senior Member
 
pagosajoe's Avatar
 
Fleetwood Owners Club
Join Date: May 2011
Location: Southwest
Posts: 1,548
Not sure this is pertinent to your situation, but if someone reviews your post about windshield wipers not working, I thought I'd mention our experience.

We had an issue with windshield wipers on our Discovery in a snow storm at the North Rim of the Grand Canyon. Here's a link to how we "fixed" it:

Windshield Wipers Stopped - in a SNOW Storm!
__________________
Joe and Debbie, Emma the Aussie Cattle Dog who adopted us
2012 Discovery 36J, Blue Ox and Air Force One, 2010 GMC Acadia Toad
USAF (Ret) WDM http://wd0m.com
pagosajoe is offline   Reply With Quote
Old 02-14-2016, 05:44 PM   #10
Moderator Emeritus
 
Bruce C's Avatar
 
Nor'easters Club
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Dec 2011
Location: NH
Posts: 5,099
I'm not sure if my washer worked or not. I hadn't checked the washer. The motor did take care of the wiper problem though. I replaced the motor last week and as I said all is well again. Good luck. Keep me informed, would like to see it fixed.
__________________

__________________
Bruce & Nancy
FMCA F280542
2004 Bounder 35E
US Navy Vet.
Bruce C is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Smart Wheel Paddles Quit Working BHutting Entegra Owner's Forum 8 11-05-2015 08:56 PM
2010 Fleetwood Discovery Water Heater Rkkcf Fleetwood Products Owner's Forum 4 03-01-2015 10:38 AM
Memory Seat Control quit working Monfish Newmar Owner's Forum 5 01-20-2015 09:48 AM
'06 Discovery Roof Top AC Not Working Mike R RV Systems & Appliances 13 07-27-2014 10:29 AM
2010 keystone bullet slideout quit working 5string71 Travel Trailer Discussion 1 02-23-2014 08:50 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.