Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 05-20-2016, 01:03 PM   #1
Senior Member
bud01234's Avatar
National RV Owners Club
Join Date: Jun 2015
Location: florence, Ky
Posts: 155
Do i really want to try this?

Fairly new to this 98 Dolphin, and only used the black tank rinse once and it worked fine.

I Decided to plug in the rinse hose to the fitting on the side of the black tank and rinse again since it's been awhile. Turned on the water and it started spraying out of the fitting instead of going into the tank. Turned it off and tried tightening but still no go. When I loosened the fitting, there was a bit of spray back of clean (hopefully) water; nothing appeared to be going in.

I know that there is a check valve to keep from contaminating the fresh water supply so I figure the check valve is stuck and not letting the fresh water in. I'm hesitant to try poking around on the check valve and possibly getting a shot of unmentionable stuff in the face.

I'm open to suggestions-


1998 National Dolphin 36' 5360 GM with tag axle.
Using my segway for a toad.
bud01234 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-20-2016, 01:19 PM   #2
Senior Member
bdpreece's Avatar
Monaco Owners Club
Join Date: Mar 2000
Location: Woodburn Oregon USA
Posts: 2,344
Had a similar problem only a couple of weeks ago. In my case I removed the tank flush fitting from the top of the black tank (three screws and some silicone) and found all the spray holes clogged with toilet paper. This is the second time this has happened since we have owned the coach. Used a drill bit to enlarge the holes a little bit and cleaned and reinstalled. Working good again.

Brian, Loretta & Daisy (Golden Retriever)
2008 Holiday Rambler Endeavor 40 PDQ , ISL 400
2014 Ford Explorer toad
bdpreece is offline   Reply With Quote
Old 05-20-2016, 01:21 PM   #3
dea49's Avatar
Join Date: Mar 2016
Location: Gainesville, FL
Posts: 66
Mud dauber nest in the fitting?
dea49 is offline   Reply With Quote
Old 05-20-2016, 01:28 PM   #4
gateaux01's Avatar
Join Date: Apr 2016
Posts: 86
Had a similar situation. I could hear water going into the tank just not very strong. After finding where the sprayer enters the tank. (Hardest part) I removed the spray nozzle and cleaned out the nozzle with a paper clip. There were several holes. Mine has a shut off valve but not a check valve. This greatly improved the flow rate into the tank.
gateaux01 is offline   Reply With Quote
Old 05-21-2016, 10:37 AM   #5
Senior Member
bud01234's Avatar
National RV Owners Club
Join Date: Jun 2015
Location: florence, Ky
Posts: 155
Thanks everybody... not sure if my fixit skills are up to messing around with the black tank; probably will have to get somebody to check it out for me.

Thanks again,
1998 National Dolphin 36' 5360 GM with tag axle.
Using my segway for a toad.
bud01234 is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Please Mr Custer i don't really want to go gutsgolf iRV2.com General Discussion 3 01-03-2014 06:11 AM
anyone try 1 of these they look really portable johnnyreno Entegra Owner's Forum 31 10-16-2013 03:45 PM
Why is my Genset Coolant really, **REALLY** low?? MN_Traveler Class A Motorhome Discussions 4 07-01-2012 06:02 AM
Really, really, really dumb question.... Nuiloa Class A Motorhome Discussions 7 05-18-2012 01:03 PM
This really really sucks ninos iRV2.com General Discussion 45 04-23-2012 06:37 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:52 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.