Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 07-12-2015, 07:33 PM   #15
Senior Member
Join Date: Nov 2006
Location: Grayson, GA
Posts: 861
I once had the same problem with my Cummins 8.3 ISC. The last shop where I had it serviced changed both filters but, they used too small a micron filter for the second filter -- I think it was a 4 micron filter. Cummins recommends that BOTH filters be 10 microns -- I changed out the fuel filters to both being 10 micron filters and no problems since.

Dave and Karen -- '02 Ultimate Advantage 36 C, 350 HP Cummins, Allison 3060 Tranny
'07 Ford Escort, Brake Master 4160, '13 Ford Edge, InvisiBrake
David K is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-14-2015, 11:38 PM   #16
Senior Member
Thor Owners Club
Join Date: Jul 2015
Posts: 149
I picked up the rig from Freightliner today, they said the Allison 3000 transmission had incorrect calibrations installed from the factory. So they reflashed the trans computer and updated the engine computer with the latest calibrations as well. The service writer told me they did change both fuel filters because of the low power issue but did not say if that made any improvement or not.

I took it out on a 10 mile road test on the open highway and it does seem to have good pickup and power, the real test will be up some hills though.

FWIW, my rig has 15,900 miles on it, I know for certain the fuel filters are not covered under warranty and they did not ask me to pay for their replacement. (Kudos to them!) I am uncertain what the culprit really was in this situation. I'll cross my fingers they have it fixed.

I was happy with Freightliner's service department, they were helpful and kept me informed about the repairs, and over the weekend they put my rig inside the shop to keep it out of the 110f Phoenix heat.

Agaveguy is offline   Reply With Quote
Old 08-24-2015, 08:45 PM   #17
Senior Member
Join Date: Aug 2015
Posts: 133
I had exactly same problem with Cummins ISL 400.Going up hills it would get that dead spot and buck. Putting your foot into it did nothing. Would loose 10 MPH and once over the hill she would slowly gain RPM and away we would go. Restricted fuel problem. Changed filters twice. Ended up being my lift pump.They are supposed to put out mininum of 5lb pressure mine was like 1.5lb pressure. They are a bearcat to change on the ISL.
Now i cruise like i should and going up steep grades the torque converter does it's thing and i have power plus.

RIDER FAN is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Best way to cut alum. diamond plate kustom Just Conversation 29 03-19-2015 08:32 PM
Mechanical Battery Cut Off Switch BPoland Newmar Owner's Forum 43 12-27-2014 09:27 PM
Wheel cut rdfugere Class A Motorhome Discussions 13 10-03-2014 10:59 AM
All coach interior lights cut out but come back on pierider Monaco Owner's Forum 14 05-27-2014 05:59 AM
Wheel Cut ? MoHoGo Class A Motorhome Discussions 11 05-12-2014 07:19 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:53 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.