Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-11-2015, 09:21 PM   #1
Junior Member
 
Monaco Owners Club
Join Date: Sep 2015
Posts: 6
dynasty 2008 with no dash gauges shown

The gauges and speedometer are not registering. Anybody have a clue that can help.
__________________

__________________
dosokies is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-11-2015, 09:28 PM   #2
Senior Member
 
bdpreece's Avatar
 
Monaco Owners Club
Join Date: Mar 2000
Location: Woodburn Oregon USA
Posts: 2,594
Start by disconnecting the batteries (pull the ground cable don't just shut off the battery disconnect). Wait about two minutes and reconnect. Worked for me when all my gauges went out.
__________________

__________________
Brian, Loretta & Daisy (Golden Retriever)
2008 Holiday Rambler Endeavor 40 PDQ , ISL 400
2014 Ford Explorer toad
bdpreece is offline   Reply With Quote
Old 09-11-2015, 09:34 PM   #3
Junior Member
 
Monaco Owners Club
Join Date: Sep 2015
Posts: 6
We tried that and still the same. Thanks. The airbrake indicator light stays on.
__________________
dosokies is offline   Reply With Quote
Old 09-13-2015, 09:44 AM   #4
Junior Member
 
Monaco Owners Club
Join Date: Sep 2015
Posts: 6
I tried it again and I got the gauges back. Thanks, but why does it randomly loose the gauges?
__________________
dosokies is offline   Reply With Quote
Old 09-13-2015, 10:50 AM   #5
Junior Member
 
Monaco Owners Club
Join Date: Jul 2014
Location: Airdrie, Alberta
Posts: 15
Dash Guages

I have been told that it is ground problem that Monacos have

My guages start to work after driving 30-50 miles

Apparently, there is supposed to be a ground post on the fire wall on the drivers side where all dash grounds are teminated. The post and connectors should be cleaned and re-tightened

I have been under there twice and can't find it!!!

If anyone knows where to locate the ground I would be much appreceiated
__________________
Colin Jarvis is offline   Reply With Quote
Old 09-13-2015, 01:08 PM   #6
Senior Member
 
bdpreece's Avatar
 
Monaco Owners Club
Join Date: Mar 2000
Location: Woodburn Oregon USA
Posts: 2,594
Glad to hear it solved your problem. This is definitely a ground issue but since it has only happened twice in the last five years I have not really spent too much time trying to remedy it. Guess I really should look for the ground post.
__________________

__________________
Brian, Loretta & Daisy (Golden Retriever)
2008 Holiday Rambler Endeavor 40 PDQ , ISL 400
2014 Ford Explorer toad
bdpreece is offline   Reply With Quote
Reply

Tags
dash, gauges



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 dynasty landrover90 Monaco Owner's Forum 9 07-01-2015 07:44 PM
Dead dash gauges in 2008 Beaver Contessa squinky Monaco Owner's Forum 2 06-16-2015 09:24 PM
Freightliner Dash Gauges Not Working LPD218 Freightliner Motorhome Chassis Forum 7 06-12-2015 04:18 PM
No gauges, all dash lights on, no Medallion corprimo Freightliner Motorhome Chassis Forum 10 04-04-2015 12:55 AM
2008 Dynasty 42' Diamond IV Question Just For Fun Monaco Owner's Forum 12 06-27-2014 08:53 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:03 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.