Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-25-2011, 10:01 PM   #1
Senior Member
 
mrschwarz's Avatar
 
Winnebago Owners Club
Texas Boomers Club
Freightliner Owners Club
Join Date: Jul 2006
Posts: 876
Send a message via Skype™ to mrschwarz
I don't have a lot of experience, but could it be a loose wire between the generator and controller? I am assuming the fault signal is the lamp blinking signal that tells you the operating condition of the generator.
__________________

__________________
Michael
2017 Allegro Bus 45OPP, Cummins ISL 450, Allison 3000
mrschwarz is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-01-2011, 07:44 PM   #2
Senior Member
 
bobmac's Avatar
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Mar 2008
Location: Southern Ontario
Posts: 924
Michael:

You might want to download the EC30 Operation and Installation manual. I believe the fault signals come in on the "Genset Status Light" line on pin 6 of the connector that plugs into the rear of the EC30. I believe this line provides the fault signal as well as flashes the lights on the dash generator start switch when cranking. If the light on that switch doesn't flash when cranking, might be worth checking the connections on the plug at the generator.
If the dash light does flash, the connection to the cable at the the rear of the EC30 may have gone open. I installed an EC30 in my previous class C and the plug that goes into the EC30 comes with 18 inch leads on it to connect to the correct wire on the coach. The connection to these leads could be where the connection has gone open.
This should make more sense when you look at the wiring diagram in the back of the EC30 manual. Hope this helps and good luck,
__________________

__________________
Bob
09 Journey 39Z
Southern Ontario
bobmac is online now   Reply With Quote
Old 07-01-2011, 10:01 PM   #3
Senior Member
 
mrschwarz's Avatar
 
Winnebago Owners Club
Texas Boomers Club
Freightliner Owners Club
Join Date: Jul 2006
Posts: 876
Send a message via Skype™ to mrschwarz
I was responding to someone else's request. I don't know where it went. I am not having a problem with mine. The original poster disappeared!
__________________
Michael
2017 Allegro Bus 45OPP, Cummins ISL 450, Allison 3000
mrschwarz is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
poor cell phone signal " I found the answer" IamGadget Technology: Internet, TV, Satellite, Cell Phones, etc. 26 10-22-2010 07:29 PM
How to determine if a cable signal is at the park post jamescle Technology: Internet, TV, Satellite, Cell Phones, etc. 3 10-31-2009 12:45 PM
Direct TV No Satelite Signal Mike R Technology: Internet, TV, Satellite, Cell Phones, etc. 9 08-13-2009 10:08 AM
No Power to Left Turn Signal at Hitch tbussche Ford Motorhome Chassis Forum 7 05-19-2009 03:33 PM
Turn Signal acting weird jhirizarry Freightliner Motorhome Chassis Forum 5 10-04-2007 07:25 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.