Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 11-16-2015, 03:26 PM   #1
Junior Member
leshchat's Avatar
Join Date: Jul 2015
Posts: 19
Electrical issue found in interesting place

4 am: Heat pumps wake me up making strange noise...trying to start but cannot, I turn on the Generator thinking power outage at the park and would get it addressed after wake up, have the power island checked...working fine so I turned off Generator and started having same trouble! IM thinking ..just great I have an inverter going out now....just what I needed. So took out voltmeter and started checking everything and found that the neutral leg was open somehow... I checked the 50 amp outlet. all was ok, wnt to the ATS switch was getting bad read on Neutral. Then I thought the Plug itself had some play in the electrodes soi would put a new one on....no luck same problem. No way it could be the power cord. it didn't have any bad spots or burn marks on it. went and bought a new one anyway and after removing the automatic take up reel I saw that it wasn't a straight forward roll-up-the-cord type of reel but a more sophisticated apparatus with a set of brushes on the spindle in a sealed box. Long story made short... it was the dang take up reel with bad brushes. So herein lies the 2 fold question, has anyone else ever experienced that problem?? and can those be services or do I just shell out $700 and replace the entire reel apparatus. Monaco Diplomat 2006

leshchat is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-16-2015, 03:55 PM   #2
Junior Member
Join Date: Jan 2012
Posts: 5
Take it from someone that has had to replace their reel 3 times…. Take it out and hard wire the power cord. If it is made by Glendenning they have had problems with the reel for quite some time. The brushes arc and wear out and they can't be replaced. Its not worth the money for a new one!!!!

woolleyspc is offline   Reply With Quote
Old 11-16-2015, 08:28 PM   #3
Senior Member
krivanj's Avatar

Fleetwood Owners Club
American Coach Owners Club
Spartan Chassis
Join Date: Oct 2009
Location: Fort Pierce, FL
Posts: 564
I fixed my friend's that was doing the same thing... We just cut off the cord and reattached the plug. He fixed it permanently by trading it in on a brand new Allegro bus last summer.
Revolution LE 38X C9 Cat
2011 Scion TC toad
1985 KLR 600 as a backup...
krivanj is offline   Reply With Quote
Old 11-17-2015, 07:09 AM   #4
Senior Member
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 21,174
You need to change your subject: That is not a "Strange Place" in fact for rigs with take up reels it's suspect #1.
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 11-17-2015, 07:34 AM   #5
Senior Member
Join Date: Feb 2010
Posts: 4,278
Check motor re builders for brushes as the manufacturer may have used something already in the marketplace.

Possibly welder or generator use.
Tony & Lori
1989 Country Coach Savannah SE
TQ60 is offline   Reply With Quote
Old 11-17-2015, 07:40 AM   #6
Senior Member
Tiffin Owners Club
Freightliner Owners Club
Join Date: Aug 2014
Posts: 1,670
There was a post where the guy rebuilt his cord reel brushes.....or had them rebuilt at a generator shop.

Or it may have been the Tiffin site, bug it is possible.

2014 40QBH Phaeton DP Cummins 380HP ISL, Freightliner XC, 2014 Jeep Trailhawk TOAD
Blue Ox Aventa tow bar, SMI Air Force One -South Orange County Ca.
dpinvidic is offline   Reply With Quote
Old 11-19-2015, 09:06 PM   #7
Senior Member
Rich-n-Linda's Avatar
Join Date: Nov 2011
Posts: 884
Originally Posted by woolleyspc View Post
Take it from someone that has had to replace their reel 3 times…. Take it out and hard wire the power cord. If it is made by Glendenning they have had problems with the reel for quite some time. The brushes arc and wear out and they can't be replaced. Its not worth the money for a new one!!!!

The brushes arc? Say what?

You should NEVER run the cable reel for the power cord while it is still carrying current! If you follow this procedure there is no opportunity for the brushes to arc because they are never carrying any current while the reel is moving.

My cable reel is now 9 years old and still works fine.

2006 Mandalay 40E, Cummins ISL 400 HP

Rich-n-Linda is offline   Reply With Quote

ace, electrical

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
found a great place and thought I should share AspireDoug Entegra Owner's Forum 14 11-05-2015 10:28 PM
electrical issue in my Forest River Ultralite 2008 primaldiva Travel Trailer Discussion 8 08-31-2015 06:52 PM
Electrical Issue Fred1609 iRV2.com General Discussion 18 08-14-2015 10:19 PM
1988 Corsair Sovereign 36T motorhome electrical issue. bkej Class A Motorhome Discussions 0 05-21-2015 02:34 PM
Electrical Issue with Marker Lights JRPA Monaco Owner's Forum 17 10-22-2014 11:09 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:46 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.