Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-24-2014, 01:11 PM   #1
Junior Member
 
Newmar Owners Club
Join Date: Jul 2014
Posts: 7
Electrical Problem

I have 2012 Newmar Canyon Star 3920 toyhauler and am having problems with the chassis battery going dead while plugged into shore power. I have checked the battery and connections and all are good. Any help would be appreciated.
__________________

__________________
bo1116 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-24-2014, 01:17 PM   #2
Senior Member
 
jfran304's Avatar
 
Tiffin Owners Club
Workhorse Chassis Owner
Join Date: Oct 2009
Location: Warner Robins, GA
Posts: 2,486
If your Newmar is like our Tiffin Allegro the chassis batteries are not charged while hooked up to shore power. Only the house batteries are charged while hooked up to shore power.

I hook up a battery tender to the chassis battery to keep it charged.

Jon
__________________

__________________
Jon & Sue Francis (Retired U.S.A.F.)
Lil Girl-Rescued, Abby Rescued, Peaches Rescued
06 Allegro 35TSA Workhorse Chassis
2013 Chevy Spark Dinghy
jfran304 is offline   Reply With Quote
Old 11-24-2014, 04:51 PM   #3
Senior Member
 
Monaco Owners Club
Join Date: Jul 2011
Posts: 162
I have the same problem, I bought a small 8"x11" $50 solar panel for the front window, I plug it into the cigarette lighter & It trickle charges my chassis batteries.
__________________
The Girls & Newman
42' 2005 Beaver Patriot Thunder
cfyanes is offline   Reply With Quote
Old 11-24-2014, 05:36 PM   #4
Senior Member
 
rvarner's Avatar
 
Winnebago Owners Club
Solo Rvers Club
Freightliner Owners Club
Join Date: Jan 2007
Location: Pahrump, NV
Posts: 461
Quote:
Originally Posted by bo1116 View Post
I have 2012 Newmar Canyon Star 3920 toyhauler and am having problems with the chassis battery going dead while plugged into shore power. I have checked the battery and connections and all are good. Any help would be appreciated.
I thought the mfgs had fixed this problem by 2012. I have installed a Trik-L-Start on both coaches I have owned to cure this problem.
Rich
__________________
2004 Horizon 40AD/ISC 350/2012 SILVERADO or 2008 Chevy HHR/Demco/Vmspc/FMCA-F394912/SKP-115085/2004 Can-Am Outlander/2013 Polaris RZR
rvarner is offline   Reply With Quote
Old 11-24-2014, 08:23 PM   #5
Senior Member
 
2 Stroker's Avatar
 
Join Date: Nov 2009
Location: Warren, Oregon
Posts: 1,717
Mine came with an echo charge and it went out so I installed this one
http://www.amazon.com/MAGNUM-MAGN-ME...=1416881629312
This one will work also EZ install.
AMP-L-START Starting Battery Charger/Maintainer - Overview Page
2 stroker
__________________
2006 Country Coach Inspire 360 40ft Genoa Designer Series, Samsung 197 RR
Cat C9--STEEL & COPPER Bolt Together Radiator w/ updated rubber mounting
SilverLeaf 330 Magnum 2812 PSW 2011 Ford Edge Sport-Air Force One
2 Stroker is offline   Reply With Quote
Reply

Tags
electrical



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical problem or what? BT-III Monaco Owner's Forum 8 10-22-2014 10:02 PM
1996 Terry Electrical Problem HighKountry Travel Trailer Discussion 4 09-22-2014 11:50 AM
Electrical problem - won't shut off Stevetoo Freightliner Motorhome Chassis Forum 3 06-22-2014 11:37 AM
2004 Windsor electrical problem Jmyates Monaco Owner's Forum 4 04-18-2014 02:46 PM
A/C electrical problem. Bwainsp Class A Motorhome Discussions 4 11-01-2013 01:58 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:54 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.