Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 04-22-2014, 07:11 AM   #1
Join Date: Mar 2014
Posts: 30
Electrical problem and slide hesitation in Bounder

Some of my 12 volt lights stopped working a few days into a trip from Arizona to Maryland. Seems near the same time, my slide motor started hesitating when pushing outward, but coming in just fine.
I noticed a few days into the trip that the converter/inverter box was just hanging from its wires. The inverter/converter is/was attached to the underside of one of the outside compartments.
Could any if this be related? I live in Annapolis and may need a recommendation for a repair center.
Thank you for your ideas,

outofdodge is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-22-2014, 09:02 AM   #2
Join Date: Oct 2010
Posts: 75
OK, without knowing the age of the unit (year & Model) I'll give you a couple ideas. On the Converter/inverter check the connections, follow the 12 volt wires out of it and see if they connect to a circuit breaker. If so, could be that the breaker looks ok but is bad. You can check voltage on each side of it to determine that.
Good Luck and keep us posted on what fixes it.
Kent and Sally Lunda
1996 Newmar Mountain Aire/Slide 300HP Cummins8.3C
2004 Honda Odyssey (Toad)
Kjlunda is offline   Reply With Quote

bounder, electrical, slide

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Winnebago Vista 30T slide out problem qcable iRV2.com General Discussion 10 09-30-2015 10:39 PM
2002 Frontier 305S Slide Problem Texas Bohunk Travel Trailer Discussion 3 02-26-2014 07:59 PM
Replacing Carpet Found Slide Problem bgbranch Monaco Owner's Forum 3 02-06-2014 05:57 AM
Slide problem Tiffin Phaeton Denise casan MH-General Discussions & Problems 9 09-05-2013 11:59 PM
Itasca 40AD Slide Problem Margaritaman Winnebago Industries Owner's Forum 10 07-22-2013 10:51 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:55 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.