Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 11-08-2010, 03:57 PM   #43
Junior Member
Join Date: Apr 2010
Posts: 16
Hello All,

Well, After replacing the serpentine belt a couple of weeks ago my wife and took our usual 3 hour trip up north leaving on that Friday afternoon and returning home Sunday evening. We again headed back up north this past weekend which would give a total of approx 600 miles of travel without ANY engine noise.. Not sure why but it seems that the belt was the problem all this time???? Crazzzzzzy

We truly thank everyone whom took the time to assist us with this.
Thanks again
Bob & Donna

whiterhino11 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
What Filter is better RattlenRam Workhorse and Chevrolet Chassis Motorhome Forum 76 01-22-2010 09:14 AM
Error code 15 on 3126 engine Renegades Caterpillar Engine Forum 2 10-07-2008 11:48 AM
Workhorse R Series Chassis With New CAT Engine Powers Models From Gulfstream Coach DriVer RV Industry Press 1 01-04-2008 04:39 AM
Loud engine noise JimmyP MH-General Discussions & Problems 8 10-06-2007 09:56 AM
Too much engine heat and engine noise rver1776 Workhorse and Chevrolet Chassis Motorhome Forum 4 08-01-2005 07:21 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:50 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.