Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 09-16-2013, 10:33 PM   #1
Junior Member
Join Date: Aug 2013
Posts: 3
Fantastic roof top fan not working

Hello everyone! I turn the panel buttons and all I get is minimal movement with the crank, but the fan does not turn. Went on the roof top to try to troubleshoot and check the electrical. Now the cover will not seal back over the fan securely. Dies anyone have any ideas? The electrical wires are all in place but still not working.

Cayannie is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-16-2013, 10:44 PM   #2
Senior Member
Skip426's Avatar

Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 11,954
The fantastic fan will not run unless the lid is 2>3" open can you raise the lid manually , usually pulling the crank down 1/2" disconnects the power drive for manual opening.
What year is your coach ? Are all the switches on the unit at the roof or is there a wall mounted control?
Should have asked , do you have the manual for your fan?

99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 09-16-2013, 10:57 PM   #3
Senior Member
chboone's Avatar

National RV Owners Club
Ford Super Duty Owner
Join Date: Sep 2010
Location: Horse Town USA, CA.
Posts: 2,703
Did you try forcing the lid open? Could have bent the lift arm. Mine got bent by high wind with it part way open, would not close all the way after that. Took it a part re-bent the arm, works fine now.

Chuck & Teri, 1999 35 ft. Dolphin 5350, F53 Chassis with tag axle, Chassis build date 1/99 in Mexico, Banks System, Trans Command, Air Lift Air Bags on rear, Koni Shocks, Blue OX TruCenter, TigerTrak track bars front and rear, Roadmaster 1-3/4" rear auxiliary sway bar, 2013 VW Passat TDI SEL Premium, 1994 36 ft. Avion 5th Wheel. FMCA #F430129
chboone is offline   Reply With Quote
Old 09-17-2013, 05:08 AM   #4
Senior Member
clyon51's Avatar
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Mar 2012
Location: Presently White Tank Mtn Regional Park, AZ
Posts: 3,757
If the lid was up high enough to release the plunger switch and the fan did not come on, I would say the plunger switch was stuck down. Has happened to me once and some penetrating oil took care of that. You access the switch up top with the lid open.

As far as the lid problem, I would disconnect the lid from the arm. Go up top and check open and closing manually looking for obstructions, bent arm sllde gulde or missing screw from it.
John & Clare - Buck & Zeus - Jack & Husky
2008 Fleetwood Bounder 38P
Towd: 2 HD Streetglides
clyon51 is offline   Reply With Quote
Old 09-17-2013, 07:12 AM   #5
Senior Member
Dupdyke's Avatar
Join Date: May 2012
Location: Roseville MN sum / La Feria Tx winter
Posts: 547
Call fantastic fan they provide world class customer service and they did not ask me if it was in wty or not just sent me the part and instructions on how to fix it and it was easy.. They are great folks

Sheri & Don 2003 Dynasty 42" regal ISL 400
2007 Goldwing Trike Gmc 4X4 w/ autoloader for trike
Lets go we got it all loaded.
Dupdyke is offline   Reply With Quote
Old 09-17-2013, 08:36 AM   #6
Senior Member
Join Date: May 2009
Posts: 1,684
Originally Posted by Dupdyke View Post
Call fantastic fan they provide world class customer service and they did not ask me if it was in wty or not just sent me the part and instructions on how to fix it and it was easy.. They are great folks
They don't send parts for free anymore.
2001 Mountain Aire DP 4095
TechWriter is offline   Reply With Quote
Old 09-17-2013, 08:39 AM   #7
Senior Member
Clayobx's Avatar

Fleetwood Owners Club
Join Date: Dec 2011
Location: Willow Lakes RV & Golf Resort, FL
Posts: 3,082
Most likely the stuck sensor roof top. We too had this issue, lube and your on the way.
Clay & Pebble.. Miss Butter our sweet Goldie (Jan. 2005-Jan. 2015) Sissy our Border Collie
2012 Providence 42 M. Spartan Chassis, 450 ISL
Ford Edge toad, RM All Terrane, TST TPMS, SMI Air Force One, RVM95....
Clayobx is offline   Reply With Quote
Old 09-17-2013, 09:14 AM   #8
Senior Member
Join Date: Jan 2012
Location: seattle, wa.
Posts: 413
Send a message via Skype™ to LandKinaMoho
Perhaps the at the fan housing location fuse is blown or loose. Sometimes I have to wiggle it to function the fan itself, just an observation from personal experience.....
1999 National Dolphin
1995 Range Rover County SWB.
Sailor, Dickens, Zooki, Koko.
LandKinaMoho is offline   Reply With Quote
Old 09-17-2013, 09:40 AM   #9
Junior Member
time2rv's Avatar
Join Date: Aug 2013
Posts: 19
Blog Entries: 1
Is that the fan in the living area of the motor home?

Ours doesn't work

We have a 1999 Monaco Lapalma

Ours is located right next to the light fixture ...I may give them a call...it would be nice to have it working ..especially in Florida

time2rv is offline   Reply With Quote

roof, fan

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oh no Bubble in rubber roof rocky34 Class A Motorhome Discussions 5 08-06-2013 10:16 PM
Dash AC condenser fan schematic YC1 Monaco Owner's Forum 7 07-19-2013 10:32 PM
Sealing up the Roof - Problems 2000 Southwind JWLSC Fleetwood Products Owner's Forum 2 07-11-2013 08:16 PM
Class A Diesel pusher Dash AC -working or not flht95 Class A Motorhome Discussions 4 07-07-2013 05:50 PM
Going crazy with this roof leak! 229guy Vintage RV's 3 07-04-2013 07:45 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:35 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.