Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 04-10-2016, 01:23 PM   #1
Senior Member
harleyjt's Avatar
Newmar Owners Club
Workhorse Chassis Owner
Join Date: Jan 2015
Location: Olive Branch, MS
Posts: 876
Feeling pretty good today....

Yesterday I hooked up water to the coach for the first time this spring and thankfully, no leaks! Last year when the dealer winterized it when I bought it, I lost the toilet valve due to freezing. No problem this year.

Then, I realized the batteries weren't charging up when I'm plugged up to the house. It appeared I was getting power into the coach as lights and everything worked fine, but the batteries continued to decline in charge. So, I went looking for the problem and found it quickly. The negative wires coming out of the converter/charger were loose and had come out of the mounting terminal. I reattached and tightened them up and all is good. Batteries are well above 13 v now!

Sometimes its those little accomplishments that make the day worthwhile....

2005 Newmar Kountry Star Gas 3742
Workhorse W24, 8.1L/Allison 5-spd
JT, Em & the boys, Kong and George (rescued grey tabbies)
harleyjt is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-10-2016, 02:18 PM   #2
Senior Member
Join Date: May 2014
Posts: 2,496
Good for you, that is a great feeling when everything works as it should or you find a quick fix that you thought may be something worse. I have been having troubles with my chassis battery not holding a charge. I messed around with it, cleaned and tightened all the connections, and so far so good. Who knows I may replace it anyway. There's nothing better than being able to travel whenever you want, and know everything is working as it should.

Mike & Charlotte
2014 Newmar Canyon Star 3610
Orange County, California
Mike and Cha is offline   Reply With Quote
Old 04-11-2016, 03:37 PM   #3
Senior Member/RVM #90
MSHappyCampers's Avatar

Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 19,260
Good job JT! There's always something that needs fixing on an RV!
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is online now   Reply With Quote
Old 04-11-2016, 04:46 PM   #4
Moderator Emeritus
Bruce C's Avatar
Nor'easters Club
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Dec 2011
Location: NH
Posts: 5,100
It's always nice to have things work out prior to the start of the season. Have safe travels.
Bruce & Nancy
FMCA F280542
2004 Bounder 35E
US Navy Vet.
Bruce C is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Feeling pretty good coming home today... JohnBoyToo Monaco Owner's Forum 8 02-02-2016 08:32 PM
I lost a wiper today! It was pretty funny at the time... plasma800 Fleetwood Products Owner's Forum 17 04-20-2014 06:48 PM
First outing in Alpine..a few problems, but still pretty good for the first outing. StansCustoms Alpine Coach Owner's Forum 14 05-03-2011 06:54 AM
Joined up here, cuz it's a pretty good board kannonvaggon New Member Check-In 2 11-02-2010 07:20 AM
Got that good Journey feeling today RCtime Winnebago Industries Owner's Forum 8 01-23-2010 07:02 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:43 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.