Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 10-30-2014, 05:18 PM   #1
Junior Member
Join Date: Oct 2014
Posts: 4
Fleetwood Revolution

I have a 2002 Fleetwood Revolution ,My wife and I camp at a farm on the side of the mountain ( dry camp) and after a weekend of camping when we leave to come home we can smell a strong order from or black water tank? also this rig has two slides one drivers side bedroom and one drivers side from the drivers seat to the stove area. Also this just started the last two or three times we went up there. Has anyone out there had this problem in your rig ?

Ron Goshorn is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-30-2014, 05:23 PM   #2
Senior Member
stink's Avatar
Join Date: Apr 2012
Posts: 1,414
Yup!! Found one of those vent valves in the wall between throne room and shower. Ran a vent thru the roof. I found the smell maker by dumping a small bottle of perfume (cheap stuff) down the bath sink then following your nose.

Dave and Laura & two cats
02 Discovery with Accord toad
retired auto rv tech and teacher, wife rt nurse
stink is offline   Reply With Quote
Old 10-30-2014, 05:28 PM   #3
RVM#87 / Senior Member
DieselTech39's Avatar

Solo Rvers Club
Join Date: Jul 2014
Location: Ham Lake, MN
Posts: 2,844

Glad you're aboard. Best of luck on a solution to your black water odor problems. Enjoy your adventures and be safe.
Have a wonderful day!
Ken (RVM 87)
FT DP Wanna B The journey is the destination!
Retired & perfecting procrastination!
DieselTech39 is offline   Reply With Quote
Old 10-30-2014, 07:26 PM   #4
Senior Member
wildirishman's Avatar
Join Date: Jul 2008
Posts: 134
I happen to have the same rig as yours. I had this trouble and I ended up filling the black tank with water after dumping and added some black tank additive. I let it sit for a day, drained it and then flushed several times. Mine just needed a good cleaning. Good luck with yours!
Colorful Colorado
2002 Fleetwood Revolution 38B
Cummins 8.3L ISC
wildirishman is offline   Reply With Quote
Old 10-30-2014, 10:56 PM   #5
Senior Member
GregOk80's Avatar
Join Date: Dec 2012
Location: Glenpool, Oklahoma
Posts: 326
Yup my 2002 Fleetwood Revolution 40c had the same problem. Well when I found it the poor thing had been setting in storage 4 to 6 months with full black and gray tanks. YUCK! Flush and drain many times and now all is good.
GregOk80 is offline   Reply With Quote
Old 10-31-2014, 07:36 AM   #6
Senior Member
Join Date: Sep 2013
Posts: 348
You may have a bad "cheater vent". My '03 has 3; under both sinks and behind the washing machine with access from the toilet room. They have a rubber seal that sometimes gets warped. Oatey 1-1/2 in. ABS PTC In-Line Cheater Vent-39012 at The Home Depot

2003 Revolution 40C looking for a new home
2007 Monaco Signature Noble III 45'
hypoxia is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Instrument cluster issues 2004 Fleetwood Revolution alpineman1 Fleetwood Products Owner's Forum 16 10-03-2014 04:18 PM
2003 Fleetwood Revolution 40C JAWill2 Fleetwood Products Owner's Forum 26 08-29-2014 07:59 PM
110 power issues - 2002 Fleetwood revolution ksk5568 RV Systems & Appliances 1 08-10-2014 03:39 PM
2008 Feetwood Revolution 43N Csm2012 Fleetwood Products Owner's Forum 17 07-08-2014 09:07 PM
No crank when key turned to start position '07 Fleetwood Revolution rlund1 Class A Motorhome Discussions 13 12-08-2013 08:04 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:54 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.