Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-07-2016, 01:31 PM   #1
Junior Member
 
Join Date: Mar 2016
Posts: 1
Ford engine stalls

I have a 1998 36' Bounder. 460 Ford. Starts and runs until coach battery dies or is disconnected. The dash board is powered by the coach battery. Onan charges 2 6v Trojan coach batteries only. Alternator charges main 12v chassis battery only. 40 years heavy truck and equipment mechanic. I'm stumped. Previous owner had replaced battery cables.
__________________

__________________
Rixthe1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-07-2016, 02:35 PM   #2
Senior Member
 
TonyDi's Avatar


 
Join Date: Feb 2011
Location: Point Pleasant Beach, NJ
Posts: 10,421
I'm sure you'll get other ideas, but are you sure the batteries are connected correctly? What is it that makes the coach batteries go dead?
__________________

__________________
Tony & Ruth........... FMCA#F416727
Newmar Dutch Star 4320, Spartan MM Chassis, Cat C9, Jeep Grand Cherokee Hemi, Blue Ox Aventa LX, and Brake Buddy. TST 507 TPMS
TonyDi is offline   Reply With Quote
Old 03-07-2016, 03:07 PM   #3
Senior Member
 
Join Date: Jul 2014
Posts: 9,804
The chassis feed must be on the coach battery. Look for a heavy ( 10 gauge) wire on the pos. post of the house batt and move it.

Nothing will be damaged switching positive wires.

The alt output goes to the start solenoid to charge the start battery.
__________________
twinboat is online now   Reply With Quote
Old 03-07-2016, 03:25 PM   #4
Registered User
 
Gulf Streamers Club
Join Date: Jun 2010
Location: Trois-Rivieres, QC, Canada
Posts: 414
Send a message via Skype™ to normandlegra
In most gas engine mh, when running the engine, the alternator charges all the batteries, coach and chassis; connected to shore power or running the GEN will only charge the coach batteries and that is why we have to turn OFF the chassis battery while parked for a long period.
__________________
normandlegra is offline   Reply With Quote
Old 03-07-2016, 04:07 PM   #5
Senior Member
 
Join Date: Jul 2014
Posts: 9,804
Quote:
Originally Posted by normandlegra View Post
In most gas engine mh, when running the engine, the alternator charges all the batteries, coach and chassis; connected to shore power or running the GEN will only charge the coach batteries and that is why we have to turn OFF the chassis battery while parked for a long period.
That is true but the solenoids that do that, are prone to failure.

The OP needs to get the engine to run on the battery that starts it first.
__________________
twinboat is online now   Reply With Quote
Reply

Tags
engine, ford



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Any Ideas? Engine stalls Annadams Ford Motorhome Chassis Forum 13 04-14-2015 11:30 AM
Engine stalls when cold start up CountryFit Cummins Engines 5 02-21-2014 08:57 PM
Engine stalls after warming up wheelsturnin Newmar Owner's Forum 5 12-30-2013 12:15 AM
generator stalls when running RV engine cueman Ford Motorhome Chassis Forum 17 06-30-2012 09:52 PM
Generator stalls on bumps drp46 New Member Check-In 5 08-20-2007 02:14 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:38 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.