Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 01-26-2015, 08:17 AM   #1
Join Date: Dec 2014
Posts: 30
Front Toilet trouble!

Bath and half Fleetwood 2012 Providence. Front toilet keeps stopping up! It always seems to have pressure because when you push dump lever it blows back up every time. It blows so hard sometimes it blows stuff out of toilet. Where could this pressure be coming from? It does this even before there is really anything in the tank. Anybody else had this problem?

GAS 13 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-26-2015, 08:30 AM   #2
Senior Member
Country Coach Owners Club
Join Date: Jan 2011
Posts: 817
How long has it been going on? Was it in storage for awhile? Have you tried flushing the front and the rear at the same time? When was the last time you dumped your tanks? I would suspect a clogged vent pipe but that's based of residential plumbing. I don't know what kind of set up you have in your rig.
Good Luck

pumper9x9 is offline   Reply With Quote
Old 01-26-2015, 08:59 AM   #3
Join Date: Dec 2014
Posts: 30
I have only had this coach a few months. It has done this since I bought it. It has this pressure even after the tank has been dumped and flushed. It seems to stop up when you flush it. I have looked down in it when you flush and can't see anything. The tube below the toilet has a elbow in it and can't see into the tank. I have been able so far to take a wire rod and hold the valve open and fish it until it moves the obstruction and emptys. Does not stop up on every flush. Seems that the more paper the worse it is.
GAS 13 is offline   Reply With Quote
Old 01-26-2015, 09:05 AM   #4
Senior Member
Pelledan's Avatar
Join Date: Sep 2010
Posts: 279
Check to see if its vent pipe is clear. It sounds like it may be plugged which would allow a positive pressure to build when the tank warms. If the vent is plugged, the only pressure escape is through opening (flushing) the toilet itself.

Pelledan is offline   Reply With Quote
Old 01-26-2015, 09:42 AM   #5
Senior Member
CampingCajun's Avatar
Join Date: Jul 2014
Location: Lafayette, La.
Posts: 1,094
Sounds as if the vent is plugged. Try blowing a little air (with someone holding the flush pedal down & an old towel over the bowl) from the roof to see if it clears up. You may also try snaking it from the roof.
2011 40' Monaco Cayman PBQ ISC 360
2013 Jeep Wrangler Unlimited
CampingCajun is offline   Reply With Quote
Old 01-26-2015, 09:54 AM   #6
Senior Member
Workhorse Chassis Owner
Join Date: Jun 2007
Location: Coaldale, AB
Posts: 232
Sounds too me that when they cut the hole at the factory they let the cut out piece drop into the tank. That's what happened to ours. Until I dug that piece out I had all kinds of grief.

05 Itasca Sunova 29R
TAN is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Toilet Problems 10-95 Forest River Owners Forum 4 03-16-2015 01:59 PM
Toilet woes Rusty years RV Systems & Appliances 9 02-15-2015 03:07 PM
Front Brakes Oil Soaked copper58 Freightliner Motorhome Chassis Forum 35 02-09-2015 08:58 PM
Aria II Electric Toilet Flange Issue John Nash RV Systems & Appliances 4 10-30-2014 05:16 PM
Next on the agenda - New front leveling valves ScottRussell Class A Motorhome Discussions 3 01-23-2014 01:40 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:03 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.