Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 10-08-2016, 12:10 PM   #1
Junior Member
Join Date: Oct 2016
Posts: 1
Furnace issue

Hello everyone, I am new to the forums and have a question regarding my furnace. It is a atwood 8535 and everything seems to function as far as blower and ignition, heat cycling and all but when I open the vent for duct access I can see flame. Seems to me that flame should be completely concealed inside the burner box and shouldn't even see reflection. Am I correct in my assumption?

NewRvOwnr is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-08-2016, 01:30 PM   #2
Senior Member
ronjhall's Avatar

Join Date: Oct 2011
Posts: 913
Welcome to iRV2.
I would say you are correct. You should not see any flame when looking in from one of the heating vents.
2004 Endura 6340D
2012 Chevy Captiva toad
ronjhall is offline   Reply With Quote

ace, furnace

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
1987 Fleetwood Southwind furnace issue themoodys7 Fleetwood Products Owner's Forum 5 07-24-2012 07:00 PM
Furnace ground issue j griff Winnebago Industries Owner's Forum 8 12-19-2011 07:55 PM
gulfstream sunvoyager furnace issue tak RV Systems & Appliances 5 03-05-2011 07:10 PM
Furnace problem may not be in the furnace! turkeychuckt MH-General Discussions & Problems 3 02-03-2010 03:26 PM
Southwind 36D Issue after issue after issue.... fixn2gocamp Fleetwood Products Owner's Forum 4 10-21-2009 07:05 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:03 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.