Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 07-02-2016, 09:20 PM   #1
Join Date: Jul 2014
Location: Lubbock, Texas
Posts: 50
Generator auto start

My Winnebago has an 8K diesel generator with the cummins W30 auto start. It works fine if only one AC is in operation. If two or three are in operation, the generator shuts down when one AC is satisfied and restarts in about 15 seconds. Anyone else have this problem? What was the fix?

Jack Robnett Lubbock, Tx
2015 Winnebago Journey 42e
2009 Buick Enclave
jrobnett is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-02-2016, 10:11 PM   #2
Senior Member
mccrob's Avatar
Join Date: Feb 2012
Posts: 260
Hope you find out mine does the same thing with both airs on. Shows code 33 witch is over heat. Did it this week when temps were 108-112 in Az

Bob & Elaine McClelland and the spoiled pup Izzie
2008 Monaco Diplomat
Desert Hills & Parker Az
mccrob is offline   Reply With Quote
Old 07-03-2016, 08:34 PM   #3
Senior Member
bobmac's Avatar
Winnebago Owners Club
Freightliner Owners Club
Join Date: Mar 2008
Location: Southern Ontario
Posts: 677
Winnebago install the EC-30 (no W) hardwired unit in their class A DPs. It has up to three possible internal connections to the house thermostat. It is likely that they only wired the unit to one zone of your multi zone thermostat based on what you are observing. Once that zone has reached the set temp., it would turn off the genset. The auto start is operating properly but is likely not wired to check the other zones before shutting down. That could be why it is restarting if triggered by another zone. Suggest you contact Winnebago and ask them if the auto start should be wired to all zones or if it is behaving correctly. I would have thought that they might have wired all zones to a single input on the EC-30 to avoid the problem you are experiencing. Sorry can't help you further. Good luck,
09 Journey 39Z
Southern Ontario
bobmac is online now   Reply With Quote
Old 07-03-2016, 08:39 PM   #4
Senior Member
IASM's Avatar
Join Date: Nov 2013
Posts: 383
I have a country coach and the auto start is wired to the front air. The other two will come on if the gen is providing power. I try to let the front one run the show so I keep it a little lower then normal.
IASM is offline   Reply With Quote
Old 07-04-2016, 01:47 AM   #5
Senior Member
SuperGewl's Avatar
Winnebago Owners Club
Ford Super Duty Owner
Join Date: Aug 2004
Location: Oregon
Posts: 1,317
Originally Posted by jrobnett View Post
My Winnebago has an 8K diesel generator with the cummins W30 auto start. It works fine if only one AC is in operation. If two or three are in operation, the generator shuts down when one AC is satisfied and restarts in about 15 seconds. Anyone else have this problem? What was the fix?
Take a look at the drawing on the Winnebago site to see if it connected to all 3. You may want to download all of the drawings to your MH for future use. Just my .01 worth of advice.
Retired Navy Submariner
2014 Itasca Sunstar 35F; 5 Star tuned; 2014 Jeep Cherokee TrailHawk
SuperGewl is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan EC-30 auto start issues...won't start for HVAC CALL jstdreamin MH-General Discussions & Problems 7 05-24-2016 11:04 AM
Generator Auto Start Greyhound Gulf Stream Owner's Forum 3 02-08-2009 05:01 AM
auto generator start unclejohn Newmar Owner's Forum 13 08-31-2007 11:29 AM
Auto Generator Start rgb1111 Alpine Coach Owner's Forum 11 06-14-2007 02:39 AM
Generator auto start??? Don Renouf Winnebago Industries Owner's Forum 13 01-23-2006 04:51 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:21 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.