Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-14-2016, 09:27 AM   #1
Junior Member
 
Join Date: Feb 2016
Posts: 8
Generator does not charge house batteries

Ok I have a 1997 coachmen catalina. The generator does not charge the house batteries or power anything in the motorhome. It does run the ac when on. and shore power everything works as it should. I have looked everywhere but behind the Magnetek converter for the ats. So is this where its at?
__________________

__________________
whataboutbob is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-14-2016, 09:35 AM   #2
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 18,105
If the a/c works via the genset, then the transfer switch is working ok. It sounds more like your battery(s) and/or converter/charger are offline or broken some how. That's where the 12v power comes from, whether on genset or shore power.

Is this a 30A RV, or 50A? One a/c or two? If two, do both a/c run via genset? I ask because there are wiring differences that may affect the diagnosis.

To answer your question, the ATS is probably behind the Magnetek - that is a common location. It will be wherever the genset and shore power cord come together, and the usual locations are (1) in the compartment where the shore cord enters the coach, or (2) behind the 120vac load center (breaker panel).
__________________

__________________
Gary Brinck
Former owner of 2004 American Tradition
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Old 02-14-2016, 09:50 AM   #3
Senior Member
 
FreedomDream's Avatar
 
Join Date: Aug 2012
Location: fulltiming
Posts: 294
There is a circuit breaker on the generator. You have blown that breaker. Re set the breaker on the generator, make sure all the appliances are off (in other words remove the load from the generator), start the generator and let it come up to operating temperature. The first thing that will come on automatically will be the charger (there may be up to a two minute delay before the charger comes on if you have a surge guard). After that is on, you can start to put a load on the generator.
__________________
Bob & Joan Alexander, 2010 Tiffin Phaeton 36 QSH, 2013 Jeep Wrangler (toad)
Lobo & Juniper (woof, woof)
FreedomDream is offline   Reply With Quote
Old 02-14-2016, 09:57 AM   #4
Junior Member
 
Join Date: Feb 2016
Posts: 8
nope it not the breakers on the generator checked them they are both on and putting out 120. that is one of the things I checked before I posted.
__________________
whataboutbob is offline   Reply With Quote
Old 02-14-2016, 10:00 AM   #5
Junior Member
 
Join Date: Feb 2016
Posts: 8
Its a 30 amp. And you can only run one Ac at a time on generator.
__________________
whataboutbob is offline   Reply With Quote
Old 02-14-2016, 10:30 AM   #6
Junior Member
 
Join Date: Feb 2016
Posts: 8
Batteries were replaced lase year. So its got to be the ats or the converter/charger. but as you know you have to check everything first be for replacing parts. Or you will just be spending money where its not needed to be spent.
__________________
whataboutbob is offline   Reply With Quote
Old 02-14-2016, 10:49 AM   #7
Senior Member
 
Join Date: Dec 2013
Location: Plantation, Fl
Posts: 1,072
Unless someone added an automatic transfer switch, that Catalina probably doesn't have one (my 1997 Catalina didn't have one). I had to plug the shore power cord into a 30A receptacle in the same enclosure the shore power cord comes from, to get generator power to the house.


In reading the OP, I missed the part where the generator powers the air conditioner. I guess it has an ATS - disregard my post.
__________________
2014 Itasca Spirit 31K
2016 Mazda CX5, on an Acme tow dolly, 4 trips 5800mi
Now 2017 RWD F 150 with a drive shaft disconnect
Mich F is offline   Reply With Quote
Old 02-14-2016, 10:51 AM   #8
Senior Member
 
Join Date: Sep 2012
Posts: 5,992
As was said, the generator feeds AC to the house that in turn feeds the converter and the A/C's. If the Air conditioner compressors turn on you have AC power out of the generator.

Given the year did you buy it new or recently acquire it? It sounds like somebody might have changed the wiring so they could run the A/C without running the house. I'd start by checking the AC input to the converter and working backwards to the panel and then transfer switch. You can also do most of that with the power off using a continuity checker/ohm meter.

The reason I can see that done is to run the A/C off the generator when driving and charging the battery from the engine alternator instead of the converter.
__________________
nothermark is offline   Reply With Quote
Old 02-14-2016, 11:40 AM   #9
Junior Member
 
Join Date: Feb 2016
Posts: 8
I recently acquire it. It does run the A/C off the generator when driving but not charging the batteries. the House batteries do charge when driving it. where is the AC input to the converter. That is why I think the ats is not working right.
__________________
whataboutbob is offline   Reply With Quote
Old 02-14-2016, 12:24 PM   #10
Senior Member
 
FreedomDream's Avatar
 
Join Date: Aug 2012
Location: fulltiming
Posts: 294
Quote:
Originally Posted by whataboutbob View Post
I recently acquire it. It does run the A/C off the generator when driving but not charging the batteries. the House batteries do charge when driving it. where is the AC input to the converter. That is why I think the ats is not working right.
I am suspecting the ATS now, too. If you can access The ATS, plug into shore power and give the ATS box a good wrap with the handle of a big screw driver to help free up the stuck switch. If you can remove the cover of the ATS you can use an electrical lubricant like CRC 2-26 on the hinge points of the switch and plug into shore power then start the generator to make it switch. Good luck.
__________________
Bob & Joan Alexander, 2010 Tiffin Phaeton 36 QSH, 2013 Jeep Wrangler (toad)
Lobo & Juniper (woof, woof)
FreedomDream is offline   Reply With Quote
Old 02-14-2016, 12:32 PM   #11
Junior Member
 
Join Date: Feb 2016
Posts: 8
Yes but where is the ast at? And if its behind the converter box a good wrap with the handle of a big screw driver will be kind of hard to do. And I'm looking behind the converter box today.
__________________
whataboutbob is offline   Reply With Quote
Old 02-14-2016, 12:59 PM   #12
Senior Member
 
FreedomDream's Avatar
 
Join Date: Aug 2012
Location: fulltiming
Posts: 294
Quote:
Originally Posted by whataboutbob View Post
Yes but where is the ast at? And if its behind the converter box a good wrap with the handle of a big screw driver will be kind of hard to do. And I'm looking behind the converter box today.
Follow the electrical cord from the outside into the coach. It should be a gray box or black box BEFORE the inverter. You can do the same with the generator power cord. It, too, will be before the inverter.
__________________
Bob & Joan Alexander, 2010 Tiffin Phaeton 36 QSH, 2013 Jeep Wrangler (toad)
Lobo & Juniper (woof, woof)
FreedomDream is offline   Reply With Quote
Old 02-14-2016, 02:10 PM   #13
Senior Member
 
Join Date: Dec 2013
Location: Plantation, Fl
Posts: 1,072
Quote:
Originally Posted by whataboutbob View Post
I recently acquire it. It does run the A/C off the generator when driving but not charging the batteries. the House batteries do charge when driving it. where is the AC input to the converter. That is why I think the ats is not working right.
What size/model Catalina do you have ? Is your house battery switch turned off ? The alternator on your MH engine should be charging the battery while you're driving.

You said the house batteries DO charge while driving. In my mind I read DON'T charge while driving. I better quit replying to this thread.
Oh wait, I just read it again. You said the house batteries don't charge while driving and they do charge while driving - which is it ?
__________________
2014 Itasca Spirit 31K
2016 Mazda CX5, on an Acme tow dolly, 4 trips 5800mi
Now 2017 RWD F 150 with a drive shaft disconnect
Mich F is offline   Reply With Quote
Old 02-14-2016, 02:25 PM   #14
Junior Member
 
Join Date: Feb 2016
Posts: 8
Well I found the ats and with the generator running I have power to the black wire and not the white. So I'm thinking its the converter. Its original so its time to up grade.
__________________

__________________
whataboutbob is offline   Reply With Quote
Reply

Tags
batteries, generator, house batteries



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Charging House Batteries jtermini30 MH-General Discussions & Problems 7 11-17-2016 09:08 AM
I think I killed my 6-volt house batteries bud01234 National RV Owner's Forum 27 09-29-2015 12:15 PM
House Batteries Wont Charge Honey_Hole National RV Owner's Forum 65 01-22-2015 08:54 AM
House batteries losing charge quickly Ramzfan Winnebago Industries Owner's Forum 18 10-30-2014 06:54 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.