Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-21-2011, 05:18 PM   #1
D M
Senior Member
 
D M's Avatar


 
Tiffin Owners Club
Join Date: Oct 2011
Posts: 115
Generator Question

When you start my generator it does not work If you turn off and restart it works. It is like on 2nd start it works. What is wrong? Thanks for your help.
__________________

__________________
Don
2008 Tiffin Phaeton
360 Cummins
D M is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-21-2011, 05:26 PM   #2
Senior Member
 
dsbike's Avatar
 
Winnebago Owners Club
Join Date: Jan 2010
Location: Hampstead, NC
Posts: 1,391
What type of generator do you have? It is possible that the fuel is not getting to it & during the first attempt it is priming itself. Then on the second attempt it has fuel, ignition, air & compression so it starts. All 4 must be present for a 4 stroke engine to run.
To start my generator (Onan 5000) I must first hold switch in off position for about 15-20 seconds to prime the fuel, then go to start & it will start right up. If I forget to prime it it takes about 30 seconds of cranking before it will start.
__________________

__________________
Dan Sees, Full Timing in the MH & Part timing in a S&B In Hampstead, NC
2013 Winnebago Journey 42e, 2014 Featherlite Car Hauler 3110 17.5', 2008 Mazda MX5,
2008 Toyota FJ Cruiser
dsbike is offline   Reply With Quote
Old 12-21-2011, 05:56 PM   #3
D M
Senior Member
 
D M's Avatar


 
Tiffin Owners Club
Join Date: Oct 2011
Posts: 115
sorry it starts and runs but will not put out a/c on first start
__________________
Don
2008 Tiffin Phaeton
360 Cummins
D M is offline   Reply With Quote
Old 12-21-2011, 06:13 PM   #4
Senior Member
 
bluepill's Avatar
 
Join Date: Jan 2011
Location: Pensacola, FL
Posts: 2,246
Quote:
Originally Posted by D M View Post
sorry it starts and runs but will not put out a/c on first start
It is normal to have about a 30 second delay after the generator starts before the AC connects.
__________________
2008 Itasca Meridian 37H & 2015 Flagstaff T12RBST
2011 & 2012 Len & Pat's "One lap of America"
27K miles & 41 states in 13 months - Woo Woo
Yellowstone Lake 6-1-2012
bluepill is offline   Reply With Quote
Old 12-21-2011, 06:19 PM   #5
D M
Senior Member
 
D M's Avatar


 
Tiffin Owners Club
Join Date: Oct 2011
Posts: 115
Quote:
Originally Posted by bluepill View Post
It is normal to have about a 30 second delay after the generator starts before the AC connects.
It can run 5 min and wont connect until turn off and restart.
__________________
Don
2008 Tiffin Phaeton
360 Cummins
D M is offline   Reply With Quote
Old 12-21-2011, 07:57 PM   #6
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 4,382
It is hard to troubleshoot from a distance, but my first thought is the transfer switch. High resistance in the points and they won't conduct. a second try and they work.
__________________
1998 Pace Arrow 35 ft. F53 Ford V10 2012 Honda Civic toad
32 years mechanic at Delta Air Lines 15 year motorhome service manager. 3 popups....2 travel trailers....5 motorhomes....loved them all.
ga traveler is offline   Reply With Quote
Old 12-22-2011, 07:32 AM   #7
D M
Senior Member
 
D M's Avatar


 
Tiffin Owners Club
Join Date: Oct 2011
Posts: 115
Quote:
Originally Posted by ga traveler View Post
It is hard to troubleshoot from a distance, but my first thought is the transfer switch. High resistance in the points and they won't conduct. a second try and they work.
I will look into that. Thank you all for the help,I think this site is great!
__________________
Don
2008 Tiffin Phaeton
360 Cummins
D M is offline   Reply With Quote
Old 12-22-2011, 08:33 AM   #8
Senior Member
 
ctpres's Avatar


 
Ford Super Duty Owner
Join Date: May 2010
Location: Chasing 70 degrees in lower 48
Posts: 1,890
Instructions for our gen say to hold start switch for two or more seconds to "flash the field."
__________________

__________________
ctpres is offline   Reply With Quote
Reply

Tags
generator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:22 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.