Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-25-2015, 06:09 PM   #1
Member
 
Join Date: Jul 2009
Posts: 44
Generator will not start

Story for you guys. I left the coach on without being plugged in for a few weeks. This killed the batteries. I jumped the coach and got it stated and charged all the batteries. The generator will not start along with the set of walkie talkies . There is no current going to the generator. I have a 2004 Winnebago Journey. I probably will try jumping the gen set tomorrow! Any answers ?? The fuse for the walkie talkies is good , all breakers are good, with no codes on the gen set.
__________________

__________________
mdshedman is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-25-2015, 06:50 PM   #2
Senior Member
 
Join Date: Jul 2014
Posts: 9,899
The gen. starts off the house batteries. Do you have lights and water pump working ?

Maybe they are dead and not charging from the engine alternator.
__________________

__________________
twinboat is offline   Reply With Quote
Old 09-25-2015, 07:28 PM   #3
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 4,597
What make model of generator do you have?
__________________
Jim J
2002 Monaco Windsor 38 PKD
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is offline   Reply With Quote
Old 09-25-2015, 07:33 PM   #4
Member
 
Join Date: Jul 2009
Posts: 44
Generator will not start

The house batteries are charged now. Lights , water pump etc run !That's an Onan diesel 7 kW . I have plenty of fuel.
__________________
mdshedman is offline   Reply With Quote
Old 09-25-2015, 07:38 PM   #5
Senior Member


 
Join Date: Apr 2012
Posts: 1,495
Quote:
Originally Posted by mdshedman View Post
Story for you guys. I left the coach on without being plugged in for a few weeks. This killed the batteries. I jumped the coach and got it stated and charged all the batteries. The generator will not start along with the set of walkie talkies . There is no current going to the generator. I have a 2004 Winnebago Journey. I probably will try jumping the gen set tomorrow! Any answers ?? The fuse for the walkie talkies is good , all breakers are good, with no codes on the gen set.
Have you measured the voltage on the house batteries, I know you said "charged all batteries" but did you?

When you say the "Gen won't start" - and there is no current going to the generator - this would imply no voltage there either - but how did you measure the current? Just curious.

Need to check all connections and switches and take voltage measurements to isolate the problem area. Is your Batt disconnect switch or "salesman switch" controlled relay in the open position?

So many possibilities but it would appear that your problem is no voltage getting to the Gen. Or perhaps/likely to other areas on the coach.

Good luck
__________________
Libero is offline   Reply With Quote
Old 09-26-2015, 10:32 AM   #6
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 18,085
The generator may start off the chassis batteries instead of house (mine does). Try the Boost (Emergency Start) switch and see if that helps.

Where are you checking the "current going to the generator"? The start switch engages a solenoid, which then connects the genset starter to the battery source. If you measure on the genset side of that solenoid and found zero (with the switch engaged), then the problem is the solenoid or starter switch. Of course, without someone to push the start switch, there would be no power anywhere past that solenoid.

You probably have at least two start switches, a remote plus one on the genset. Does either one work?
__________________
Gary Brinck
Former owner of 2004 American Tradition
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Old 09-26-2015, 10:32 AM   #7
Senior Member
 
Country Coach Owners Club
Join Date: Jan 2006
Location: Redding
Posts: 3,412
Diesel or Gas or Propane?

Won't Start?

Starts but will not Run?

Engine starts, runs, but shuts down?

The owners manual usually has trouble shooting steps in chart form. If you do not have one you can get one for your rig online.
__________________
Dean
1995 CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
deandec is offline   Reply With Quote
Old 09-26-2015, 07:22 PM   #8
Member
 
Join Date: Jul 2009
Posts: 44
Diesel, will not start. Also no disk player or walkie talkies. Everything else runs on coach!
__________________
mdshedman is offline   Reply With Quote
Old 09-27-2015, 08:38 AM   #9
Senior Member


 
Join Date: Apr 2012
Posts: 1,495
Quote:
Originally Posted by mdshedman View Post
Diesel, will not start. Also no disk player or walkie talkies. Everything else runs on coach!
As I understand your situation. You do not have 12V present at the generator starter when you push the start button. Is this correct?

You also do not have a 12v supply to your disk player and Walkie Talkies. But every other 12V system is working in the coach. Is this correct?

(The latter re disc playet etc may be coincidental and not related to the Gen Start - don't know at this stage)

What happened when you selected the emergency start button and tried to start the Gen as suggested in another post?

You need to isolate the problem and start taking voltage measurements at various places.

Go to the generator and push the start button right on the gen. If no relay noise is heard start checking voltage going back from the starter and relay circuit.

(Check all connections of course and every switch, breaker/fuse and relay associated with the start circuit)

You will find coach schematics extremely helpful - for this and so many other troubleshooting scenarios. Suggest you get schematics if you do not have. Winnebago have good schematics that can be downloaded. Or draw your own if you can trace the wires. Should not be difficult to do for a Gen Start circuit and check voltages as you go to each point in the circuit.

Good luck - hope this helps but you
__________________
Libero is offline   Reply With Quote
Old 09-27-2015, 09:53 AM   #10
Senior Member
 
OLYLEN's Avatar
 
Monaco Owners Club
Join Date: Jan 2008
Location: Olympia, Wa
Posts: 2,338
When you push the start switch do you get the priming pump/clicking sound or does the Gen turn over and not start? Do you have the intermittent switch to turn of or on house batteries or the manual switch? Sounds like there is also a 120 volt problem from things that don't work, for these see the breakers on the inverted/converter.

LEN
__________________
2004 Clss C 31' Winnebgo
OLYLEN is offline   Reply With Quote
Old 09-27-2015, 10:04 AM   #11
Junior Member
 
Douginbc's Avatar
 
Join Date: Apr 2013
Posts: 7
My gen would not start until a Tech told me to switch the house batteries on, and away it went.
__________________
Douginbc is offline   Reply With Quote
Old 09-27-2015, 10:59 AM   #12
Member
 
Join Date: Jul 2009
Posts: 44
There is no priming or anything going to the generator. I am going to look up the diagram from the switch today !
__________________
mdshedman is offline   Reply With Quote
Old 09-27-2015, 03:01 PM   #13
Member
 
Join Date: Jul 2009
Posts: 44
Dumb me, I started reading the user manual and found there is a 15 amp fuse inside the access panel on top of the generator! It's was bad, replaced it all is good !
Thank you!
__________________
mdshedman is offline   Reply With Quote
Old 09-27-2015, 05:43 PM   #14
Senior Member
 
Country Coach Owners Club
Join Date: Jan 2006
Location: Redding
Posts: 3,412
Thank you for posting the resolution.

Your post will likely be of help to someone else.
__________________

__________________
Dean
1995 CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
deandec is offline   Reply With Quote
Reply

Tags
generator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Will not start and Allison transmission key pad does not light on start Jeff753 Monaco Owner's Forum 28 12-03-2017 07:54 PM
Engine will not start normally from key switch David K Spartan Motorhome Chassis Forum 14 07-17-2015 12:16 PM
RV Won't Start - Please Help - 1999 Newmar Dutch Star with Cat 3126 Bradstewart Caterpillar Engine Forum 31 07-05-2015 12:50 AM
Auto Gen Start (RC7GS) Terry L T Technology: Internet, TV, Satellite, Cell Phones, etc. 6 06-16-2015 02:54 PM
2000 Dutch Star - no start issue DragRacer68 Newmar Owner's Forum 18 06-15-2015 09:36 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:04 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.