Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-27-2011, 11:25 PM   #1
Junior Member
 
Join Date: Nov 2011
Posts: 5
Generator won't stay running

1999 Dutch Star, 300 hp cummins, spartan chassis with Kubota powered 7K generator. Generator starts and runs for about 15 minutes then quits. Will restart immediately and run for 5+- seconds then quit again. If left for an hour will then start and run for 15 minutes again. Have so far replaced fuel pump, filters, oil pressure sensor. Fuel tank is full. Is there a filter in the tank or could there be an issue with the fuel line pickup set to high? Anyone had the same issue?
__________________

__________________
LarryWeaver is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-28-2011, 04:49 AM   #2
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
Push the "STOP" button for one second after it has shut down; you will see it blinking three times and then you will get a series of blinking lights. Count them. This will tell you the nature of the shut down. The fault code blinks are in the owners manual. If you don't have one, it can be down loaded here:http://www.cumminsonanstore.com/ It could be that the "Over Temp" fault is the culprit. This could be a bad pump, belt or sensor causing the shut down. Let us know what you find.
__________________

__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 11-28-2011, 11:01 AM   #3
Senior Member
 
Country Coach Owners Club
Join Date: Jan 2006
Location: Redding
Posts: 3,412
If the Kubota is in a Powertech 7.0 then I have had a similar problem.

In my case the voltage regulator in the power generation portion was bad and needed to be replaced.

I tried to diagnose the problem myself first.

I bought a Fuel Shut Down solenoid and installed it. That change made no difference.

I replaced the fuel filter and rechecked its install and decided it was not an air leak.

I checked the oil, fuel, and temp shutdown modes. They seemed to be ok.

The generator mechanic did the fix.

I do not know if there is a fuel filter in the tank, but there is one on my generator.

In my generator manual, there is flow chart for troubleshooting various symptoms of non-performance. It could be helpful if you have one also.
__________________
Dean
1995 CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
deandec is offline   Reply With Quote
Old 11-28-2011, 04:39 PM   #4
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 18,073
Doesn't sound like a fuel pick-up problem to me, but it could be a fuel LINE problem, e.g. a hairline crack or pinhole such that it eventually gets an air bubble instead of fuel.

But first tell us if there is any diagnostic code, per the instructions given by RV Wizard. That info can save a lot of guessing.
__________________
Gary Brinck
Former owner of 2004 American Tradition
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Old 11-28-2011, 09:12 PM   #5
Junior Member
 
Join Date: Nov 2011
Posts: 5
Thanks to all who have replied. Great suggestions. Where is the fuel shutdown solenoid? This is a powertech generator unit.
__________________
LarryWeaver is offline   Reply With Quote
Old 11-29-2011, 11:25 AM   #6
Registered User
 
Join Date: Mar 2011
Location: SW Florida
Posts: 933
Quote:
Originally Posted by Gary RVRoamer View Post
Doesn't sound like a fuel pick-up problem to me, but it could be a fuel LINE problem, e.g. a hairline crack or pinhole such that it eventually gets an air bubble instead of fuel.

But first tell us if there is any diagnostic code, per the instructions given by RV Wizard. That info can save a lot of guessing.
I agree. My gen did the same thing and it was a small crack in the fuel line.
__________________
Billieg is offline   Reply With Quote
Old 11-29-2011, 01:22 PM   #7
Senior Member
 
Country Coach Owners Club
Join Date: Jan 2006
Location: Redding
Posts: 3,412
The Fuel solenoid is on the same side as the fuel filter, but located near the upper rear of the unit.

Here is a link to a newer PT Generator Manual that looks very similar to my 1994 manual.

http://powertech-gen.com/wp-content/...ORS-MANUAL.pdf

Go to the rear of the manual page 52 PDF to find the trouble shooting flow chart for "Engine starts but won't run" chart.

Again, I thought my problem was a fuel problem.

It turned out to be a AC power generation problem that prevented the engine from continuing to run.
__________________

__________________
Dean
1995 CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
deandec is offline   Reply With Quote
Reply

Tags
generator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ordered New 40QXP Bus today; Problem is where to Stay while RV is being Built JOLT Tiffin Motorhomes Owners Forum 12 11-17-2011 09:35 PM
Suburban WH won't stay lit MojaveJoe RV Systems & Appliances 7 02-23-2010 01:16 PM
Running the generator while on shore power? Magumba Winnebago Industries Owner's Forum 9 01-14-2010 09:03 PM
Diesel Generator won't stay running Mike-N-Sally Winnebago Industries Owner's Forum 8 01-01-2010 01:08 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:57 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.