Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-01-2012, 08:40 AM   #1
Senior Member
 
denochs's Avatar
 
Fleetwood Owners Club
Join Date: Oct 2009
Location: North Carolina
Posts: 702
Genny Slide not closing all the way

We have an 03 American Eagle with a 10kw genny on a front end slide out. It is not closing all the way. Leaves about an inch or two. The motor doesn't sound as strong as it used too.

Checked hydraulic fluid and bled the line at the front connector to the piston. Anything else you knowledgeable folks have for me?

Dave
__________________

__________________
David & Gail Salisbury, NC
2003 American Eagle 42'
denochs is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-01-2012, 09:53 AM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,970
I think you have to get under the back of the gen set, and check that the power cable hasn't come loose from it's supports and jaming the slide.
Any service history on the gen set ? Record of fuel and air filter changes? How many hours on it ? Brand ?
__________________

__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 10-01-2012, 08:08 PM   #3
Senior Member
 
denochs's Avatar
 
Fleetwood Owners Club
Join Date: Oct 2009
Location: North Carolina
Posts: 702
It's a Onan 10K with about 1300 hrs on it. All the service has been performed on it with oil and filters.

Don't think it can be the power cable as it does move in and out slower than normal. And it just won't close all the way. Like I said, leaves about and inch or two gap.

Anything else it might be?

Dave
__________________
David & Gail Salisbury, NC
2003 American Eagle 42'
denochs is offline   Reply With Quote
Old 10-01-2012, 11:39 PM   #4
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,970
Possible rusted roller bearing on the slide, loose mounting bolt, jamming up the works. Only way to be sure is look over the whole slide from every angle. If it sounds different possible tailpipe damage.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 10-02-2012, 10:04 AM   #5
Senior Member
 
calhyatt's Avatar


 
Newmar Owners Club
Freightliner Owners Club
Join Date: Mar 2012
Location: Weston, Fl.
Posts: 914
Quote:
Originally Posted by denochs View Post
We have an 03 American Eagle with a 10kw genny on a front end slide out. It is not closing all the way. Leaves about an inch or two. The motor doesn't sound as strong as it used too.

Checked hydraulic fluid and bled the line at the front connector to the piston. Anything else you knowledgeable folks have for me?

Dave
Are you speaking of the electric hydraulic motor or the engine on the generator?
__________________
2003 Newmar Kountry Star 3905, Freightliner XC chassis with CAT 330. Winnie the black lab, pretty Airbus captain wife, retired airline pilot with 11 grandkids. UH-1 pilot (Huey) U.S. Army 1967-1983. RVN 68-69. Northern Idaho my summer home.
calhyatt is offline   Reply With Quote
Old 10-03-2012, 06:53 AM   #6
Senior Member
 
denochs's Avatar
 
Fleetwood Owners Club
Join Date: Oct 2009
Location: North Carolina
Posts: 702
The generator itself is running fine. It's the slide, hydraulics, or electric motor that's keeping it from closing all the way.

Plan on working on it today if the rain lets up. We're at the coast in Holden Beach, NC thru the week and really don't want to drive the coach with it open.

Dave
__________________

__________________
David & Gail Salisbury, NC
2003 American Eagle 42'
denochs is offline   Reply With Quote
Reply

Tags
slide



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:24 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.