RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-14-2018, 05:06 PM   #1
Senior Member
 
rvadventure's Avatar
 
Monaco Owners Club
Join Date: Aug 2015
Posts: 311
Got a software update and lost power!!

Recently I took the coach in to a truck shop and they changed my serpentine belt, and did the software updates. When I picked it up it didnít seem to have as much get up and go, but I thought it was my imagination. I headed up the mountain today and I really had a lot less power than usual. If I put it on cruise control it goes like it always did. Iím not sure what happened? Any ideas? The engine is a cummins 425 HP. ISL. Regards
__________________

__________________
2009 Monaco Camelot 425 HP Cummins ISL 40QDP
Toad- 2011 ford- flex tow 4 wheel down
rvadventure is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-14-2018, 05:15 PM   #2
Senior Member
 
FatChance's Avatar
 
Join Date: Mar 2015
Posts: 1,474
What response did the shop that did the work tell you when you called?
__________________

__________________
'04 Newmar Mountain Aire 4016
400ISL/Freightliner
FatChance is offline   Reply With Quote
Old 06-14-2018, 05:22 PM   #3
Senior Member
 
ThePowells's Avatar


 
Join Date: Mar 2017
Location: Zebulon, NC
Posts: 3,263
It is possible that a previous owner or shop changed the engine profile to add HP or torque and the update restored the factory settings.
__________________
Kelly and Jerry Powell with Halo (Lethal White Aussie), Nash the Rat Terrorist, and now Reid, the "Brindle we have no idea puppy"
2017 Thor Quantum W31, Ford E-450, Onan QG4000, Demco Kar Kaddy, Toytoada Prius.
ThePowells is online now   Reply With Quote
Old 06-14-2018, 06:56 PM   #4
Senior Member
 
Join Date: Aug 2017
Posts: 391
Got a software update and lost power!!

Quote:
Originally Posted by rvadventure View Post
...If I put it on cruise control it goes like it always did....

This confirms that there is nothing wrong with the engine or itís programming. It also confirms that there IS something wrong with the throttle position sensor. You can push the pedal all the way to the floor, but the engine doesnít know itís wide open.
A Traveler is offline   Reply With Quote
Old 06-14-2018, 07:57 PM   #5
Senior Member
 
ThePowells's Avatar


 
Join Date: Mar 2017
Location: Zebulon, NC
Posts: 3,263
I don't know about now, but I know that the early DD60 engines would produce what ever was programmed, but would produce max rated HP when the cruise was on and the set / accel switch toggle was held in the accel position.
__________________
Kelly and Jerry Powell with Halo (Lethal White Aussie), Nash the Rat Terrorist, and now Reid, the "Brindle we have no idea puppy"
2017 Thor Quantum W31, Ford E-450, Onan QG4000, Demco Kar Kaddy, Toytoada Prius.
ThePowells is online now   Reply With Quote
Old 06-14-2018, 08:35 PM   #6
Senior Member
 
rvadventure's Avatar
 
Monaco Owners Club
Join Date: Aug 2015
Posts: 311
Quote:
Originally Posted by FatChance View Post
What response did the shop that did the work tell you when you called?
I havenít asked them yet, mainly due to I donít have a lot of confidence in them. My mistake I didnít take it where I normally due because they had 40 jobs ahead of me, but they do great work. Thank you
__________________
2009 Monaco Camelot 425 HP Cummins ISL 40QDP
Toad- 2011 ford- flex tow 4 wheel down
rvadventure is offline   Reply With Quote
Old 06-14-2018, 08:38 PM   #7
Senior Member
 
rvadventure's Avatar
 
Monaco Owners Club
Join Date: Aug 2015
Posts: 311
Quote:
Originally Posted by ThePowells View Post
It is possible that a previous owner or shop changed the engine profile to add HP or torque and the update restored the factory settings.
Iíve had the updates done since then, not sure what caused it, but Iím taking it to my regular shop that has done work on all of my coaches. Thanks for the response. Regards
__________________
2009 Monaco Camelot 425 HP Cummins ISL 40QDP
Toad- 2011 ford- flex tow 4 wheel down
rvadventure is offline   Reply With Quote
Old 06-14-2018, 08:40 PM   #8
Community Moderator
 
TonyDi's Avatar


 
Newmar Owners Club
Join Date: Feb 2011
Location: Point Pleasant Beach, NJ
Posts: 14,624
I also agree that you have a problem with the throttle position sensor. If cruise control acts normal there's no engine problem such as clogged fuel filters etc. It's not convenient but use the cruise control until you can get it to your mechanic.
__________________
Tony & Ruth........... FMCA#F416727
Newmar Dutch Star 4320, Spartan MM Chassis, Cat C9, Jeep Grand Cherokee Hemi, Blue Ox Aventa LX, and Brake Buddy. TST 507 TPMS
TonyDi is online now   Reply With Quote
Old 06-14-2018, 08:40 PM   #9
Senior Member
 
rvadventure's Avatar
 
Monaco Owners Club
Join Date: Aug 2015
Posts: 311
Quote:
Originally Posted by A Traveler View Post
This confirms that there is nothing wrong with the engine or itís programming. It also confirms that there IS something wrong with the throttle position sensor. You can push the pedal all the way to the floor, but the engine doesnít know itís wide open.
I think you are right on with this assessment, I called my regular shop and they said pretty much the same thing. Thanks for the response. Regards
__________________
2009 Monaco Camelot 425 HP Cummins ISL 40QDP
Toad- 2011 ford- flex tow 4 wheel down
rvadventure is offline   Reply With Quote
Old 06-14-2018, 08:42 PM   #10
Senior Member
 
rvadventure's Avatar
 
Monaco Owners Club
Join Date: Aug 2015
Posts: 311
Not sure either, thanks for the response. Regards
__________________
2009 Monaco Camelot 425 HP Cummins ISL 40QDP
Toad- 2011 ford- flex tow 4 wheel down
rvadventure is offline   Reply With Quote
Old 06-14-2018, 08:44 PM   #11
Senior Member
 
rvadventure's Avatar
 
Monaco Owners Club
Join Date: Aug 2015
Posts: 311
Quote:
Originally Posted by TonyDi View Post
I also agree that you have a problem with the throttle position sensor. If cruise control acts normal there's no engine problem such as clogged fuel filters etc. It's not convenient but use the cruise control until you can get it to your mechanic.
Thanks Tony, Hopefully they can just replace the sensor, once you do the update I donít think you can reverse them, if that is what caused it. Regards
__________________
2009 Monaco Camelot 425 HP Cummins ISL 40QDP
Toad- 2011 ford- flex tow 4 wheel down
rvadventure is offline   Reply With Quote
Old 06-15-2018, 08:51 AM   #12
Senior Member
 
OLYLEN's Avatar
 
Monaco Owners Club
Join Date: Jan 2008
Location: Olympia, Wa
Posts: 2,705
What is your boost pressure while on full load both cruise ad foot throttle? Good tell on power out put.

LEN
__________________
2004 Clss C 31' Winnebgo
OLYLEN is offline   Reply With Quote
Old 06-18-2018, 05:58 PM   #13
Senior Member
 
rvadventure's Avatar
 
Monaco Owners Club
Join Date: Aug 2015
Posts: 311
Found the issue Yahoo!!

Quote:
Originally Posted by rvadventure View Post
Recently I took the coach in to a truck shop and they changed my serpentine belt, and did the software updates. When I picked it up it didnít seem to have as much get up and go, but I thought it was my imagination. I headed up the mountain today and I really had a lot less power than usual. If I put it on cruise control it goes like it always did. Iím not sure what happened? Any ideas? The engine is a cummins 425 HP. ISL. Regards
Well I had an appointment to get this issue looked at, but over the weekend I started looking at threads, and as usual people on this forum came up with the answer. I found a thread from 2011 that gave the instructions on how to calibrate you acellerator to the engine and transmission. I took a picture of the instructions, but didnít get the ID of the person who posted it. So whoever did this post I thank you, and will also post these easy to do instructions. My coach ran like a bat out of hell after I did the re- calibration. Regards
Attached Thumbnails
Click image for larger version

Name:	89A6DD58-1152-4280-8711-4CDD8537EC5B.jpg
Views:	14
Size:	301.5 KB
ID:	207678   Click image for larger version

Name:	8E374C20-751A-4A8E-AEC2-C9172DF8B596.jpg
Views:	17
Size:	350.1 KB
ID:	207679  

__________________

__________________
2009 Monaco Camelot 425 HP Cummins ISL 40QDP
Toad- 2011 ford- flex tow 4 wheel down
rvadventure is offline   Reply With Quote
Reply

Tags
power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HWH 2000 series software update to keep jacks retracted kraig Alpine Coach Owner's Forum 19 03-15-2011 09:28 PM
Software update - new feature Janet H Forum 101 | Announcements | Member Forum Concerns 6 08-31-2009 09:52 AM
Garmin's NEW ecoROUTE free software update Tom N Technology: Internet, TV, Satellite, Cell Phones, etc. 7 02-06-2009 11:11 AM
I GOT IT! I GOT IT!! I GOT IT!!! ronboc Workhorse and Chevrolet Chassis Motorhome Forum 7 07-22-2005 12:51 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:02 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.