Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 05-27-2016, 11:26 AM   #1
Junior Member
Join Date: Dec 2013
Posts: 2
Headlights not working right

1984 Coachmen President 33 454. the head lights do not work right. 12.3 volt power to the headlight sw./dimmer sw and to the headlight's but the HI beam's do not light up they just glow like a bad ground. I have cleaned ALL grnd to the frame, I have connected the ground wire straight to the batt. grnd. and still nothing. I can jump the light bulbs and they light up OK connect back inline and nothing. I have ran power straight from the batt to the dimmer sw. and still no HI beam's. Does anyone have any hints?
thanks Noel

mrputterer is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-27-2016, 01:33 PM   #2
Senior Member
BFlinn181's Avatar

Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 12,633

I'd hook up a separated jumper wire from a good ground to the head light fixture to see if it could be the ground wire or connectors on it. You also gave voltages to the dimmer and head light switch, what's the voltage to the plug on the head light lamp? Often dim lights are due to inadequate wiring or too long a run for the wire gauge.

12.3 v is I hope a reading with engine off, the alternator should provide more voltage than that.


Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is online now   Reply With Quote
Old 05-28-2016, 08:14 AM   #3
Senior Member
Skip426's Avatar

Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 11,950
The headlight bulbs share a common ground for high & low beam , so if the low beam works properly, the ground should be good.
You've tested the bulbs high /low direct from power and their ok .
Now in your testing have you back probed the wiring at the back of the lights when the high beams are on and just glowing , to see what the voltage is then.
It only takes milli-amps to get a reading on a volt meter, bad contacts in the headlight switch ; or a relay if your system has them; could provide the power to get a meter reading yet not pass the amps required to get the light working properly.
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 05-28-2016, 10:07 AM   #4
Junior Member
Join Date: Dec 2013
Posts: 2
Headlight's not working

Thank's to both Skip426 and Bflnn181. a few month ago I had the MH in the shop for engine work. they did not tell me they replaced both Hi and Low Light Plugs to the right headlights and wired them wrong so it was back feeding. changed the wires and all is well.
mrputterer is offline   Reply With Quote

light, lights

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Right signal lights quit working when I turn the headlights on mrbhistory Class A Motorhome Discussions 3 09-03-2014 09:23 PM
Front headlights changed to BMW E39 series headlights Rippenrick Alpine Coach Owner's Forum 13 09-20-2013 11:07 PM
Headlights not working - intermittent problem TDInewguy Freightliner Motorhome Chassis Forum 5 11-24-2008 04:15 AM
HWH Jacks working, not working and working again? Bob&Pat Winnebago Industries Owner's Forum 6 06-08-2006 04:22 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:28 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.