Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-20-2012, 08:19 AM   #1
Junior Member
 
Join Date: Jul 2011
Location: Sherrills Ford, NC
Posts: 10
Heater Fan Blower

With unit plugged into shore power, propane off, thermostat off, winterized the blower on the heat unit continues to run. when you disconnect the house batteries it is off.
Is this normal for blower to run?
__________________

__________________
Chuck C.0606 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-20-2012, 08:58 AM   #2
Senior Member
 
MartinP's Avatar
 
Rexhall Owners Group
Join Date: Aug 2012
Location: Merrill, Oregon
Posts: 567
Chuck,

I don't think that is correct. I would suggest that you locate the model number of the heater and download the installation/operation manual for the unit. It will give a description on how the unit should and a wiring diagram to help trouble shoot the problem. Sounds like you may have a relay to the motor that is sticking in the closed position.

Martin
__________________

__________________
Martin Picke'
1998 Rexhall Anthem 34' DP, Cummins ISB, Allison 5 speed, Spartan Chassis, 300 watts solar.
MartinP is offline   Reply With Quote
Old 11-20-2012, 09:11 PM   #3
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 18,073
No it is not. The fan should run for about 30 seconds after the burner cycles off, then it should shut down.
__________________
Gary Brinck
Former owner of 2004 American Tradition
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Old 11-21-2012, 08:17 AM   #4
Junior Member
 
Join Date: Jul 2011
Location: Sherrills Ford, NC
Posts: 10
Thank you both and I will download the manual and check the relay.
__________________
Chuck C.0606 is offline   Reply With Quote
Reply

Tags
fan, heater



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:12 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.