Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-08-2012, 12:30 PM   #1
Junior Member
 
Join Date: Aug 2012
Posts: 13
help help help

Hi everyone I need help My dw was shampooing the carpets in the motor home and we lost all electric. This is on a 2007 sightseer 29r we have electric to and through all breakers but nothing will work no air or any of the plug ends will work. Has anyone else had this problem any help will be appreciated wd9bob
__________________

__________________
WD9BOB is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-08-2012, 12:35 PM   #2
Senior Member
 
Shellback1's Avatar


 
Damon Owners Club
Ford Super Duty Owner
Join Date: Jul 2008
Location: Nashua, NH
Posts: 721
Send a message via AIM to Shellback1
Check and reset your GFI's.
__________________

__________________
2006 Damon Daybreak 3274 35' Ford F53 V-10
2006 Ion Retired Navy, FAA and PASS Union VP
Shellback1 is offline   Reply With Quote
Old 09-08-2012, 12:45 PM   #3
Junior Member
 
Join Date: Aug 2012
Posts: 13
shellback1 thanks for your come back now to show you how dumb i am i cant fined the gfis on my rig wd9bob
__________________
WD9BOB is offline   Reply With Quote
Old 09-08-2012, 12:46 PM   #4
Senior Member
 
sdennislee's Avatar


 
Monaco Owners Club
Winnebago Owners Club
Join Date: Sep 2011
Posts: 6,404
Have you checked the breaker on the CG pedestal? GFCI is always a good choice when you loose power to outlets but you indicate you lost all power. I doubt its the GFCIs in this case since you lost power to the air conditioning.

If you have access to a multimeter Check:
Transfer switch
Surge protector (if you have one)
Pedestal breaker
__________________
US Navy Vet, Liberty Tree Member of Oath Keepers, NRA & VFW Life Member, Alaska EMT.
2009 Safari Cheetah 40 SKQ
2009 Winnebago Chalet 231CR
sdennislee is offline   Reply With Quote
Old 09-08-2012, 12:47 PM   #5
Senior Member
 
HUCKSHAVEN's Avatar
 
Monaco Owners Club
Join Date: Nov 2011
Location: lakeland,florida
Posts: 115
Should be on a plug near the bathroom or the kitchen. Also check the circuit breaker on the inverter.
__________________
"HONEY" whats that noise ??? Ken and Cindy---- 08 MONACO CAMELOT 42'
HUCKSHAVEN is offline   Reply With Quote
Old 09-08-2012, 12:57 PM   #6
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 18,085
And if you have an inverter that powers some of the outlets, check the circuit breaker on the inverter itself.
__________________
Gary Brinck
Former owner of 2004 American Tradition
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Old 09-08-2012, 01:01 PM   #7
Senior Member
 
HD4Mark's Avatar
 
Winnebago Owners Club
Coastal Campers
Join Date: Oct 2009
Location: Marathon, Florida
Posts: 2,894
Have you tried running your generator? That is a quick way to see if it is your rig or the park power.
__________________
Mark & Nancy
2004 Winnebago Vectra 40KD
Shep dog, R.I.P. Kenzie dog Toad 2015 Jeep Wrangler Willys Wheeler
HD4Mark is offline   Reply With Quote
Old 09-08-2012, 01:07 PM   #8
Junior Member
 
Join Date: Aug 2012
Posts: 13
Smile

Thank you so much everyone that posted shellback1 nailed it I just could not fined it. Finally found it in the bed room in the computer desk. temperature had fell here so the air conditioner wouldn't work till we set it to about 30 Thanks for all your quick responses wd9bob
__________________

__________________
WD9BOB is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:32 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.