Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-03-2016, 09:29 AM   #1
Junior Member
 
Fleetwood Owners Club
American Coach Owners Club
Join Date: Apr 2015
Posts: 9
Help! MH 12v system

We are in a campground and suddenly our 12v control system is unresponsive. We have lights and fans on, but we can't turn anything off if it's on, and vice versa. We are in a 2004 American Eagle, and this is what the system looks like. Can anyone tell us where to start looking for the problem?

__________________

__________________
Ducksoop is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-03-2016, 09:33 AM   #2
Senior Member
 
vsheetz's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Jun 2012
Location: SoCal
Posts: 11,808
Is actual battery voltage low? Control systems can become confused when supply voltage is low.

How about a power reset? Remove 12v power, wait a minutes, reapply power.
__________________

__________________
Vince and Susan
2011 Tiffin Phaeton 40QTH (Cummins ISC/Freightliner)
Flat towing a modified 2005 Jeep (Rubicon Wrangler)
Previously a 2002 Fleetwood Pace Arrow 37A and a 1995 Safari Trek 2830.
vsheetz is online now   Reply With Quote
Old 04-03-2016, 01:39 PM   #3
Junior Member
 
Fleetwood Owners Club
American Coach Owners Club
Join Date: Apr 2015
Posts: 9
Bizarre. As my husband was digging around trying to find the best way to disconnect the 12v power (following advice above) the system suddenly started working normally again. This is the second time this has happened in about three months so we'd like to get to the bottom of it in case this is an early sign of something going bad. If anyone has theories, please feel free to share.
__________________
Ducksoop is offline   Reply With Quote
Old 04-03-2016, 01:46 PM   #4
Senior Member
 
Davdeb1's Avatar


 
Monaco Owners Club
Freightliner Owners Club
iRV2 No Limits Club
Join Date: Jan 2011
Location: Avon Lake, Oh
Posts: 2,884
The first thing to do is to disconnect that control system and spray it with terminal cleaner. It could just be old and corroded.
__________________
2000 HOLIDAY RAMBLER ENDEAVOR
40 FT--330HP CAT
2 SLIDES-TOAD 2012 focus
Fulltime-Home is where we park it.
Davdeb1 is offline   Reply With Quote
Old 04-03-2016, 02:27 PM   #5
Senior Member
 
gemert's Avatar
 
Monaco Owners Club
Join Date: Mar 2014
Posts: 847
Check all the connections in the area where he was when it started working again.
__________________
Jerry, "EWC (SW)" USN Retired
2003 Beaver Patriot Thunder 505 HP C-12 1550 TQ
Allison 4000MH Ram 4X4 towed
gemert is offline   Reply With Quote
Old 04-03-2016, 04:50 PM   #6
Senior Member
 
vsheetz's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Jun 2012
Location: SoCal
Posts: 11,808
Yup, contact spray. Make and remake connections. Clean connections. Look for loose connection or damaged/sometimes shirted wire.
__________________
Vince and Susan
2011 Tiffin Phaeton 40QTH (Cummins ISC/Freightliner)
Flat towing a modified 2005 Jeep (Rubicon Wrangler)
Previously a 2002 Fleetwood Pace Arrow 37A and a 1995 Safari Trek 2830.
vsheetz is online now   Reply With Quote
Old 04-03-2016, 06:05 PM   #7
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 18,105
Your lights, fans, etc. are all operated by a multiplex controller under the bed. Those switches just send a digital message to the board to turn something on or off. The board may have failed, or it may have lost power (it has its own fuse wired direct to the house battery positive terminal).

The multiplex system is made by American Technology Components. Contact them for help at American Technology Components
__________________
Gary Brinck
Former owner of 2004 American Tradition
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Old 04-03-2016, 09:00 PM   #8
Junior Member
 
Fleetwood Owners Club
American Coach Owners Club
Join Date: Apr 2015
Posts: 9
I can't begin to thank you guys enough for the helpful advice. This MH is new to us--in fact we are new to the whole RV'ing thing (this is our first one)--so we are just learning the ropes and there are a *lot* of ropes to learn for us rookies. We will follow up on each suggestion and let you know what we found out. Again, THANK YOU!
__________________

__________________
Ducksoop is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
12V Power Supply for 12V Systems JJH3rd Class A Motorhome Discussions 22 08-15-2014 09:56 PM
Issue with the 12v system. Rick 2005 Dolphin 5376 National RV Owner's Forum 40 01-09-2009 12:16 PM
Loss of 12v power to radio, 12v plugs, etc redeldo Monaco Owner's Forum 9 05-21-2008 05:34 PM
12V system RayK 5th Wheel Discussion 11 06-28-2007 11:07 AM
1989 Elite: 12v system not working RobG MH-General Discussions & Problems 9 05-27-2005 05:47 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:54 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.