Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 07-31-2015, 04:14 AM   #1
Junior Member
Join Date: Jul 2015
Posts: 2
Help No dash gauges Fuse not problem

We are suppose to leave for vacation this morning and can not find the problem. We checked fuses and wiring and can not find the problem We were driving the rv to prepare and all at once the dash board went out. It is a Coachmen Mirada with only 32000 miles Help asap.

dmct922 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-31-2015, 06:57 AM   #2
Senior Member
Kahoona's Avatar
Join Date: Jul 2015
Location: North Palm Beach FL
Posts: 261
Wow! What a pain in the rear. What year is it? Ours is a 2002 and there are at least three fuse/relay boxes. 2 of them are under the dash on the left (drivers) side and one is under the hood in the center. I would check the manual and fuse function descriptions for something that runs a processor or control module. The lamps have a single fuse but the gauges are from a variety of places. Worse comes to worse I'd pull and test every fuse with a test lamp or meter starting with the box beneath the hood. You are dealing with the Ford portion rather than the Coachmen parts. Please post the year in case someone has one and has had that problem.

Kahoona is offline   Reply With Quote
Old 07-31-2015, 05:14 PM   #3
Senior Member
Donlock's Avatar
Ford Super Duty Owner
Join Date: Dec 2006
Location: Clinton On
Posts: 162
I had this happen

no signal no brake lights etc.
Drove me nuts trying to find problem . Had 2001Coachmen aurora 348ds
Here is what I found after searching for a week or so.
Pull the dash cluster and in behind there are server all connector bundles of
Wire check or move you might hear a little arcing make sure they connect good
Then check for lights etc. I also bought a wiring book and it help a lot.
We just traded ours in.
Hope this helps if nothing else works.
2013 Georgetown 335 DS
2016 Ford Focus SE
Donlock is offline   Reply With Quote
Old 07-31-2015, 09:02 PM   #4
Senior Member
mgscott4's Avatar
Workhorse Chassis Owner
Join Date: May 2009
Location: Kansas City, MO./Pollock, LA.
Posts: 1,526
Look at your Battery Control Center (BCC). Check your chassis disconnect switch, some people call it the salesman switch by the door. make sure the chassis disconnect relay is working properly.
06 Hurricane 34FT WH W20 Chassis 8.1L 129K, Steersafe, Koni Shocks, DIY Trac Bar, Tri-Metric 2025RV Battery Monitor, 4-6V Batteries, Scan Gauge 2, Crossfires, 735W Solar Morningstar MPPT-60, KVH R5 In-Motion Sat, XM Radio, 07 Chevy Malibu Maxx Toad, Falcon 2, Brake Buddy, Escapee
mgscott4 is offline   Reply With Quote
Old 08-01-2015, 06:05 AM   #5
Senior Member
denlock's Avatar
Newmar Owners Club
Spartan Chassis
Join Date: Feb 2005
Location: Sterling Heights, MI
Posts: 2,724
Check for a bad ground wire. I had the same problem once and a small ground wire had broken at the battery.
Tricia & Dennis Lockhart
2010 Ventana 4333
Spartan MM w/Cummins 360 ISC
denlock is offline   Reply With Quote

dash, fuse, gauges

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Some Dash Gauges Dropping Out jimwrye Monaco Owner's Forum 8 08-07-2014 08:36 PM
Location of fuse for dash 12 volt power outlet Catch14me Fleetwood Products Owner's Forum 4 05-05-2014 12:46 PM
04 tradition dash gauges going crazy ted sparkes Fleetwood Products Owner's Forum 1 12-19-2013 07:05 PM
2007 Dutchstar Dash Heat problem Usa1chris Newmar Owner's Forum 10 11-06-2013 10:55 AM
Dash gauges not working Roywolf National RV Owner's Forum 10 08-29-2013 08:26 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:55 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.