Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-09-2010, 04:49 PM   #1
Junior Member
 
Join Date: Dec 2010
Posts: 3
Question Help required - winnebago chieftain 1989



Hi
We have a 1989 winnebago chieftain, which all was going well, until ....... We recently had some really bad weather, our winnie has been put away for the winter but we deceided to go and see if she was Ok, apart from finding a small leak everything was fine, then we switched on the monitor panel with lights for the tank levels etc which lit up then fade out and now wont work has anyone go any ideas please the fuses that i can find seem to be OK. I haven't a clue!!!
__________________

__________________
Sharon2751 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-09-2010, 05:03 PM   #2
Senior Member
 
ernieh's Avatar
 
Join Date: Jul 2009
Posts: 1,109
Have you checked the batteries?
__________________

__________________
ernieh
2012 Phaeton 36QSH
2007 Wrangler Toad
ernieh is offline   Reply With Quote
Old 12-09-2010, 05:09 PM   #3
Senior Member
 
GaryKD's Avatar
 
Newmar Owners Club
Join Date: Jul 2006
Location: Wellington, Florida
Posts: 12,324
Hi Sharon2751,
Welcome to iRV2. The first suspect are the coach batteries. I do not know your skill level. Do you own and are you comfortable using a volt meter?
__________________
Gary
2005 Newmar KSDP 3910 + GMC ENVOY XUV 37K lbs Moving Down The Road
The Avatar Is Many Times Around The USA
Nobody Knows Your Coach Like Somebody Who Owns One Just Like Yours
GaryKD is offline   Reply With Quote
Old 12-10-2010, 06:15 AM   #4
Junior Member
 
Join Date: Dec 2010
Posts: 3
Quote:
Originally Posted by GaryKD View Post
Hi Sharon2751,
Welcome to iRV2. The first suspect are the coach batteries. I do not know your skill level. Do you own and are you comfortable using a volt meter?
I haven't checked the batteries as everything else is working, so thought they would be Ok
__________________
Sharon2751 is offline   Reply With Quote
Old 12-10-2010, 03:30 PM   #5
Junior Member
 
Join Date: Nov 2008
Posts: 25
I too would suspect battery voltage. Have you gone to Winnebago Ind and looked for the wiring diagrams. I have a 96 motorhome and for a long time they only went to 97 online. I found the 1997 wiring diagrams worked fine. If there were no major changes from 1989 to 1990 (last year on website) you might want to download the wiring diagrams, along with the rest.
__________________
2003 Fleetwood Discovery 39S
2005 Malibu Maxx
vectra96 is offline   Reply With Quote
Old 12-12-2010, 05:21 PM   #6
Junior Member
 
Join Date: Dec 2010
Posts: 3
Hi

I have chaecked the batteries they are OK, I have found the fuse board but none have popped out (howver I can't figure which one is for the panel) any ideas please


Quote:
Originally Posted by Sharon2751 View Post


Hi
We have a 1989 winnebago chieftain, which all was going well, until ....... We recently had some really bad weather, our winnie has been put away for the winter but we deceided to go and see if she was Ok, apart from finding a small leak everything was fine, then we switched on the monitor panel with lights for the tank levels etc which lit up then fade out and now wont work has anyone go any ideas please the fuses that i can find seem to be OK. I haven't a clue!!!
__________________
Sharon2751 is offline   Reply With Quote
Old 12-12-2010, 06:23 PM   #7
Member
 
Winnebago Owners Club
Join Date: Nov 2010
Posts: 55
Quote:
Originally Posted by Sharon2751 View Post


Hi
We have a 1989 winnebago chieftain, which all was going well, until ....... We recently had some really bad weather, our winnie has been put away for the winter but we deceided to go and see if she was Ok, apart from finding a small leak everything was fine, then we switched on the monitor panel with lights for the tank levels etc which lit up then fade out and now wont work has anyone go any ideas please the fuses that i can find seem to be OK. I haven't a clue!!!
Plug in your chieftain into an outlet with the power cord on the RV. If you have a switch inside for a/c current /battery then turn it on A/C. You should have lights and power to your panel, water pump, furnace fan when plugged into an A/C outlet. I suspect your batteries are bad although the dummy panel shows they are good. Good for about 15 minutes......
__________________

__________________
Greg Lepage is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replace Brakes 1999 Winnebago Chieftain winston2112 Winnebago Industries Owner's Forum 3 09-12-2010 01:29 PM
Winnebago Industries Receives Safety Award DriVer RV Industry Press 0 05-06-2009 04:03 PM
1987 Winnebago Chieftain P30 Questions trpl600 Vintage RV's 2 02-10-2009 03:39 PM
Winnebago Industries Circle of Excellence Reciepients 2008 DriVer RV Industry Press 4 05-20-2008 04:40 AM
What's New at Winnebago Industries, Inc. DriVer Winnebago Industries Owner's Forum 4 05-14-2007 07:04 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:47 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.