Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-24-2015, 07:19 PM   #1
Senior Member
 
Join Date: May 2007
Location: Davie, Florida
Posts: 719
How to diagnose RV Water pump problems

I tried to find the answer on the search engine at the top of this page but could only find out how to replace the water pump. My pump is running but very little water comes out. When I turn off the water faucet the pump continues to run. I checked for air leaks in the water lines around the pump and the winterizing valves but could not detect any. The unit is 7 years old. It normally behaves this way after I ocassionally run the tank dry. It seems to take a while for the pump to get its prime. But now its not doing much of anything.
__________________

__________________
Denis, Ruth and Gracie
the K-9 Dashboard Ornament
2007 Newmar Baystar 3202
D in Davie is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-24-2015, 07:33 PM   #2
Senior Member
 
ARTWERKE's Avatar
 
Join Date: May 2012
Location: Deep in the Heart of Texas
Posts: 466
Do you have any type of filter at your water pump? My previous RV had a sediment bowl screen filter before the pump. It filled with sand from a campground and cut the flow way down.
__________________

__________________
2000 DSDP, 3894,Freightliner,330 Cat, 07 Jeep Commander 4x4toad.
ARTWERKE is offline   Reply With Quote
Old 04-24-2015, 09:10 PM   #3
Senior Member
 
ChasA's Avatar
 
Join Date: Mar 2007
Location: Apex, NC
Posts: 1,857
City/tank fill valve in fill position?
__________________
2010 Winnebago Journey Express 34Y
2010 Freightliner XCS (mfd 9/'09)
'07 Saturn Vue V6
ChasA is offline   Reply With Quote
Old 04-24-2015, 09:17 PM   #4
Senior Member
 
chuckftboy's Avatar
 
Fleetwood Owners Club
Holiday Rambler Owners Club
Join Date: Dec 2011
Location: North East Florida
Posts: 754
A pump will do that when it looses prime. Like Artwerke said, see if you are getting enough water to it. If you don't have a strainer, pull the pump and see if there is trash in it.
__________________
2015, HR Ambassador 38DBT / 2006 Jeep TJ Towd
340 Cummins / Freightliner Chassis
chuckftboy is offline   Reply With Quote
Old 04-24-2015, 09:25 PM   #5
Senior Member
 
mccsix's Avatar
 
Ford Super Duty Owner
Join Date: May 2010
Location: Pensacola Fl
Posts: 667
Valve(s) in the wrong position?
__________________
mccsix is offline   Reply With Quote
Old 04-25-2015, 12:45 AM   #6
Senior Member
 
Tony Lee's Avatar
 
Join Date: Sep 2012
Location: Peru heading for Brasilia, Brazil
Posts: 2,122
Depending on your plumbing arrangement, turning the tank fill valve on (with city water disconnected) bypasses water directly from the pump back into the tank making it easier for the pump to re-establish prime. One the flow is normal, turn off the tank fill valve and see if the pump operates normally.
__________________
Tony Lee - International Grey Nomad. Picasa Album - Travel Map
RVs. USA - Airstream Cutter; in Australia - MC8 40' DIY Coach conversion & OKA 4x4 MH; in Germany - Hobby Class C; in S America - F350 with 2500 10.6 Bigfoot camper
Tony Lee is offline   Reply With Quote
Old 04-25-2015, 12:22 PM   #7
Senior Member
 
Rexhall Owners Group
Join Date: Jul 2014
Location: Auburndale, Florida
Posts: 190
Quote:
Originally Posted by mccsix View Post
Valve(s) in the wrong position?
Mine was doing the same thing as you describe and this was the solution.
__________________
Mick & Vonna, 1999 Rexhall Rexair
GRUU is offline   Reply With Quote
Old 04-25-2015, 12:37 PM   #8
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,971
Did you pump RV anti-freeze through the pump during winterizing ?
Blow out the line back to the fresh tank?
Several possibilities, air leak into the pick-up line , between the fresh tank and the pump, plugged or cracked pump inlet filter ( being on the inlet side of the pump these would allow air in , but not water out ), internal cracks in the pump housing or internal valve seals.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 04-25-2015, 02:05 PM   #9
Senior Member
 
Join Date: May 2007
Location: Davie, Florida
Posts: 719
Thank you everyone. No matter how many check lists I try to develop I always forget something. ChasA had it right. I was almost going to buy a new water pump.
__________________

__________________
Denis, Ruth and Gracie
the K-9 Dashboard Ornament
2007 Newmar Baystar 3202
D in Davie is offline   Reply With Quote
Reply

Tags
water, water pump



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with water pump problem please VB Bill Entegra Owner's Forum 18 02-20-2015 08:51 PM
Hurricane 34E Water Pump jpspinks Thor Industries Owner's Forum 13 11-23-2014 09:16 PM
Water Pump Relay Location Sohapi Monaco Owner's Forum 15 03-08-2014 12:17 PM
Onboard water system problems at -8 degrees. Full.Monte MH-General Discussions & Problems 16 02-18-2014 07:37 AM
Water pump kicking on when on city water JWLSC Class A Motorhome Discussions 26 02-07-2014 05:30 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:59 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.