Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-22-2016, 01:08 PM   #1
Junior Member
 
Join Date: Oct 2015
Posts: 3
Humming in front

I have a 2007 Vectra 40' with a 400hp diesel. Recently I started the coach when I could hear a humming sound coming from the front end drivers side. I opened the front hood and found the humming was coming from some type of vacuum pump?? It has a constant humming that can even be heard from the drivers seat. It obviously never did this before. Has anyone had this issue? Do these pumps go bad often?
__________________

__________________
Rink092 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-22-2016, 01:20 PM   #2
Registered User
 
mel s's Avatar
 
Join Date: Mar 2010
Posts: 8,777
Quote:
Originally Posted by Rink092 View Post
I have a 2007 Vectra 40' with a 400hp diesel. Recently I started the coach when I could hear a humming sound coming from the front end drivers side. I opened the front hood and found the humming was coming from some type of vacuum pump?? It has a constant humming that can even be heard from the drivers seat. It obviously never did this before. Has anyone had this issue? Do these pumps go bad often?
Rink092
Not often... (my vacumm pump is 20 years old in a 147,000 mile coach)...but it can happen.
A vacuum leak which causes the pump to run continually anytime the ignition key is on is a more common problem.
Mel
'96 Safari
__________________
mel s is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GFI's humming jeeprubi RV Systems & Appliances 4 04-14-2009 09:01 PM
At Disney and the Coach is Humming Just Fine Thank You Very Much JavaJelly Newmar Owner's Forum 7 11-08-2007 01:31 PM
A/C Humming kuldaddy Damon 3 05-30-2007 05:48 PM
Inverter humming with all power off DaveOhio Winnebago Industries Owner's Forum 6 05-30-2007 03:45 PM
humming/drone/whistle at 60-65 mph bullydogs1 Workhorse and Chevrolet Chassis Motorhome Forum 9 04-05-2007 09:53 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:59 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.