Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-24-2016, 12:19 PM   #1
Member
 
fishdoc's Avatar
 
Join Date: Sep 2013
Location: Houston,Texas
Posts: 72
HWH air level

Trouble with HWH air leveler system. Not responding except for Travel
Mode and raising coach. No dumping or leveling. Past threads mention loose wire or clip in "control box". Can't find this control box,? Anyone know where it may be located on my 05 Navigator?
Probably something more involved but Ocams Razor comes to mind.
__________________

__________________
fishdoc is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-24-2016, 09:22 PM   #2
Senior Member
 
slickest1's Avatar
 
Monaco Owners Club
Join Date: Jul 2011
Location: B.C.
Posts: 3,716
Look in your storage bays. Mine is on the top side of my storage bay. It is an aluminum box. There a lots of fuses in there. I also have a couple fuses in the electrical compartment front drivers side as well for the air leveling.
__________________

__________________
Dennis & Marcie & Captain Hook The Jack Russell,aka PUP, 04 Dodge/Cummins 01 Citation 29.rk fifth wheel.RVM59
slickest1 is online now   Reply With Quote
Old 03-24-2016, 09:26 PM   #3
Senior Member
 
Mr_D's Avatar
 
Solo Rvers Club
iRV2 No Limits Club
Join Date: May 2011
Location: Vancouver, WA
Posts: 28,471
Mine is in the front electrical compartment in front of the drivers side wheel opening. Not that yours will be there but it is a suggestion of someplace to look.
__________________
2009 45' Magna 630 w/Cummins ISX 650 HP/1950 Lbs Ft
Charter Good Sam Lifetime Member, FMCA, SKP
RV'ing since 1957, NRA Benefactor Life, towing '14 CR-V
Mr_D is online now   Reply With Quote
Old 03-24-2016, 10:46 PM   #4
Senior Member
 
dons2346's Avatar
 
Country Coach Owners Club
Join Date: Dec 2010
Posts: 4,483
First think I would do is contact HWH and ask for some troubleshooting help. I know where my controller is but no use telling you because your location is different
__________________
Don
2002 Country Coach Intrigue
dons2346 is online now   Reply With Quote
Old 03-24-2016, 11:00 PM   #5
Senior Member
 
distaff's Avatar
 
Join Date: Dec 2009
Posts: 1,191
I am not sure what chassis came under the 05 Nav, but the coach is big enough that it may be an S-Series. My Patriot Thunder is built on an S-Series and it has TWO HWH boxes - one for the slides and one for levelling. The one for slides is on the firewall behind the passenger headlight.

The one for levelling is in one of the middle bays, on the ceiling of the bay, and a few feet in from the driver's side.

I had a similar problem, crawled in and pulled all the connections off the box one at a time looking for a bad one. When I put them all back it worked fine.

There is also a bubble for setting the level, but you problem doesn't sound like that is the issue.

Good luck. BTW HWH are very helpful.
__________________
Paul
2006 Patriot Thunder C13 Allison 4000
2010 Ford Flex Ecoboost AWD
distaff is offline   Reply With Quote
Old 03-25-2016, 08:53 AM   #6
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 26,314
Only problem I've had with mine was that mud daubers filled the exhaust holes on the two manifolds with mud! I could not dump the air and it would not level properly.

I just used a small drill bit (not in the drill) to open the holes. I have been planning to cement a small square of fine door screen over the holes but haven't got around to that yet!
__________________

__________________
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Reply

Tags
hwh



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HWH air level loisjop Entegra Owner's Forum 15 02-02-2016 12:23 AM
HWH Air Bags and HWH 4 Leg Hydraulic Jacks?? Just For Fun Gear and Product Discussions 6 12-06-2015 12:31 AM
Level and slide or slide then level? smackey2x Class A Motorhome Discussions 61 12-28-2010 09:42 AM
See Level II LPG level CJ7ole RV Systems & Appliances 3 11-06-2010 07:36 PM
Refrigerator...how level is LEVEL? footdoc RV Systems & Appliances 10 02-13-2007 02:46 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:37 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.