Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-21-2012, 06:49 PM   #1
Junior Member
 
jeagle's Avatar
 
Winnebago Owners Club
Join Date: Aug 2010
Posts: 22
HWH jacks and slide outs

2002 Itasca Suncruzier and the jacks or the slide out just quit. Don't click or anything. Was working fine put the mh in the garage went out to get something and they dont work. Any ideas? Have tried to check fuse's but can't fine where the fuse's are??
__________________

__________________
jeagle is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-22-2012, 12:42 AM   #2
Member
 
CalifCruiser's Avatar
 
Join Date: Apr 2012
Location: La Mesa, CA
Posts: 45
I had a similar issue with my 2002 Suncruiser in which the HWH jacks, radio, power mirrors, defrost fans, and power driver's window did not work, however the slides did work. Turns out that it was a blown fuse and all of those things are on the same circuit. There is a fuse box under the flip open drivers dash, just lift it up and start checking. They are not labeled, however I did find a diagram of the fuses in the Workhorse chassis book that comes with the RV. The fuse was the 15 amp " ACC - radio".
There is also another fuse box under the hood, drivers side, the fuses are all labled on the inside of the lid.
I'll take a closer look at my RV when I can, there is most likely a fuse for the pump motor, it may be under the front of the RV, down near the pump. i'm not much of an expert on this stuff, just a suggestion of where to start, I'm sure that someone else will be able to tell you exactly where to look.
__________________

__________________
2002 Itasca Suncruiser
CalifCruiser is offline   Reply With Quote
Old 11-22-2012, 06:36 AM   #3
Senior Member
 
rgreen45's Avatar
 
Join Date: Jun 2011
Location: Bradenton, Fl.
Posts: 706
First of all, is the jacks or the slide that quit?

Make sure your park brake switch is operating properly as most jacks won't work unless the park brake is set.
__________________
Ray G.
ASE Master Med-Heavy Trucks
RVIA Certified
rgreen45 is offline   Reply With Quote
Old 11-22-2012, 09:10 AM   #4
Junior Member
 
jeagle's Avatar
 
Winnebago Owners Club
Join Date: Aug 2010
Posts: 22
Jacks and Slides not working

Thanks for your suggestions. I reset the parking breaks and reset it in park and everything worked. Thanks again
__________________
jeagle is offline   Reply With Quote
Old 11-22-2012, 05:48 PM   #5
Senior Member
 
rgreen45's Avatar
 
Join Date: Jun 2011
Location: Bradenton, Fl.
Posts: 706
Quote:
Originally Posted by jeagle View Post
Thanks for your suggestions. I reset the parking breaks and reset it in park and everything worked. Thanks again
Glad you got the problem solved
__________________
Ray G.
ASE Master Med-Heavy Trucks
RVIA Certified
rgreen45 is offline   Reply With Quote
Reply

Tags
hwh, jacks, slide



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:31 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.