Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 01-29-2011, 06:49 PM   #1
Join Date: Jan 2011
Posts: 36
HWH lights not working

I hope I can help others on this site too at some stage. I do appreciate all the help so far with my new Monaco purchase.

My other issue I have is that the HWH air levelling system works as it should but the only light that works on the panel is the 'travel' light. No others come on. Is there a seperate fuse for these lights or a simple fix??



Oztraveller is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-30-2011, 05:11 AM   #2
Community Moderator
RV Wizard's Avatar

Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 11,807
First try disconnecting the harness from the back of the touch pad and reconnecting to insure good, clean connections. If this does not correct the problem find the HWH control box. It is usually near the pump assembly and has a clear plastic cover over the control board and a rubber seal holding it to the box. Inside the box are an array of fuses with led lights. You will need either the owners manual or service manual for this system to verify the correct led's have the correct amber or red color. If you find one wrong there is probably a fuse blown or you may find a bad control board or touch pad. Call HWH for tech support and they can walk you through diagnoses.

Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 01-30-2011, 08:25 PM   #3
Join Date: Jan 2011
Posts: 36
Thanks for the reply,

I had a good look at the system today and the manual individual raising functions are not working either. The raise, Dump and auto functions do work but no lights. I will contact HWH in the morning and run through the problem with them...hope they have good back up support for our "not so new" coaches.
Oztraveller is offline   Reply With Quote
Old 02-01-2011, 07:42 PM   #4
Senior Member
Noelj's Avatar
Join Date: Nov 2007
Location: Tennessee
Posts: 197
With any problem for HWH jacks, just call for service at HWH. I have found them to be some of the best I have ever worked with.
Noel, Betty, one poodle, one greyhound
2005 Gulfstream Ultra Supreme 30' 07 HHR Toad
Noelj is offline   Reply With Quote
Old 02-01-2011, 09:46 PM   #5
Senior Member
parmm's Avatar
Join Date: Aug 2002
Location: Little Valley, NY (Snow Country)
Posts: 160
Their web site has a excellent troubleshooting section.
parmm is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
4 way flasher lights not working 2002 w22 chassis clouddancer Workhorse and Chevrolet Chassis Motorhome Forum 1 07-04-2010 03:30 PM
Brake Lights not Working slabman Spartan Motorhome Chassis Forum 11 05-26-2009 05:30 AM
HWH leveling system not working cabin Newmar Owner's Forum 8 05-09-2009 07:57 AM
Breakaway switch and lights on a VUE mrschwarz Toads and Motorhome Related Towing 10 05-02-2007 02:01 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:37 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.