Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-13-2011, 09:17 AM   #1
Junior Member
 
Join Date: Aug 2011
Posts: 4
hydro boost problem

hydroboost coming on intermitently sometimes staying on brakewarning light and hydroboost light come on hydroboost pump runs while lights are on happens at diffrent times cant pinpoint exactly sometimes when hitting bumps others when turning then sometimes on restarts its on already any ideas on where to start
__________________

__________________
hrscott is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-15-2011, 01:05 PM   #2
Community Administrator
 
JohnRR's Avatar


 
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Sep 2010
Location: Marquette, Michigan "Da UP"
Posts: 10,316
Member lists he owns a Holiday Rambler Vactioner 36sbt
__________________

__________________
John & Cathy R.
06 Pace Arrow 38L W24
08 Lincoln MKX AWD
JohnRR is offline   Reply With Quote
Old 08-15-2011, 07:15 PM   #3
Senior Member
 
Dave78Chief's Avatar
 
Join Date: Jun 2009
Posts: 1,498
Because there are dozens upon dozens of configurations on the road, when stating a problem you really need to clearly identify what you equipment you have for people to try and help you.
Holiday Rambler only lists the Vacationer model for 2011 and used the Ford F53 chassis. The 36SBT model had a GVWR of 26,000. If that is incorrect, then please ignore the following and provide more details about what you do have.
That chassis above used a Hydromax Brake system. The service manual for that system is located here: http://alpinecoachassociation.com/ch...r%20Manual.pdf
Please review the Trouble shooting section at the end of that document and see if that answers your issue.

For reference, the Brake light is coming on because the differential pressure transducer is detecting a difference in pressure between the forward and rear systems. The Hydroboost light is indicating a loss in flow (via the flow switch) from the power steering pump supply side which is resulting in the electric emergency backup pressure pump to run (only used in emergency backup mode). The only other things that can cause all this is a defective Monitor Control module, loose connections, or low power steering fluid level (maybe loose PS belt?).

Dave
__________________
Dave78Chief is offline   Reply With Quote
Old 08-16-2011, 03:14 PM   #4
Junior Member
 
Join Date: Aug 2011
Posts: 4
Quote:
Originally Posted by hrscott View Post
hydroboost coming on intermitently sometimes staying on brakewarning light and hydroboost light come on hydroboost pump runs while lights are on happens at diffrent times cant pinpoint exactly sometimes when hitting bumps others when turning then sometimes on restarts its on already any ideas on where to start
sorry about leaving out main info rv is 2000 h/r vactioneer on ford chassis believe chassis is 12/1999
__________________
hrscott is offline   Reply With Quote
Old 08-16-2011, 05:51 PM   #5
Junior Member
 
Join Date: Aug 2011
Posts: 4
Quote:
Originally Posted by hrscott View Post
sorry about leaving out main info rv is 2000 h/r vactioneer on ford chassis believe chassis is 12/1999
and thanks for replying any info would be a big help right now its off but havent driven it out of drive i also believe the steering seemed a little stiff before this started
__________________
hrscott is offline   Reply With Quote
Old 08-17-2011, 01:13 PM   #6
Senior Member
 
Dave78Chief's Avatar
 
Join Date: Jun 2009
Posts: 1,498
From what I can decipher from the limited information on the web, you have a Hydro-max system with 4 Wheel ABS. Is that correct?
If so and you are not getting a ABS warning light, then as I indicated before, it is most likely PS hydraulic system problem. The Hydro-max unit uses the Power Steering pump hydraulic system during normal operations. It energizes the pump motor on the hydromax unit if it detects a loss of power steering hydraulic fluid. That could be due to a leak in the power steering system (low fluid level), loose PS belt, a failing PS pump, loose sensor connections (or defective sensor), failing Hydro-max control unit (under the dash), etc. The "brake light" would be linked to the differential pressure sensor (monitors pressure differential between front and rear systems). The "hydroboost light" would be linked to the flow sensor (indiacates a loss of PS hydraulic pressure ergo, energize electric backup pump). If you getting an ABS light (you didn't indicate that you are), then you will need to have some one read the the ABS codes.

The Hydro-max system is a cousin to the Hydroboost system (from the early 70's). Both are typically implemented using the PS pump hydraulics for normal operation. Where the Hydroboost system uses an accumulator as a safety backup (provides 2 maybe 3 power assisted pedal depresses), the Hydro-max uses a electric pump motor as a safety backup. For both systems, if there is a total loss of PS hydraulic fluid, there is still a mechanical connection between the master cylinder and the pedal. You just do not have the force multiplication provided by the booster.

Dave
__________________

__________________
Dave78Chief is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hazard Flasher Problem Ms. Jean Thor Industries Owner's Forum 17 08-28-2014 04:54 PM
tire inflation problem Marinelender MH-General Discussions & Problems 14 07-25-2010 10:18 AM
water ingestion problem puts4doe MH-General Discussions & Problems 5 06-30-2010 09:37 PM
Cluster problem TXredfish Workhorse and Chevrolet Chassis Motorhome Forum 5 04-24-2009 06:00 PM
Fuel Contamination Problem CampingCaptain Cummins Engines 5 04-07-2009 02:46 PM


All times are GMT -6. The time now is 01:40 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2014, vBulletin Solutions, Inc.