Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-29-2010, 04:50 PM   #1
Senior Member
 
Monaco Owners Club
Join Date: Jun 2010
Posts: 178
Blog Entries: 2
Smile in dash heater blower stopped

Out of nowhere my 96 Dynasty heater blower stopped ! With Key and blower switch all on, I used a test light to all the wires in the connector to the resistor at the Heater core box in the firewall in the Gen bay, and nothing hot ! In the front run bay outside and below the drivers window, with the engine running, all the fuses were dead, and were also dead with the key off, in the bank of fuses on the lower right! In the center bar of fuses, the only one hot was the 15Amp #3 fuse with key off and on! With key off, all the fuses in the left bank of fuses, were Hot! and cold with the Engine running! I say running so its clear the key was on! If anyone can answer the reasons so I can get this deal working, I will send you twenty bucks, if so permitted! I am not very good with electronics! Many thanks, allegro5 or greatallegro5@aol.com
__________________

__________________
allegro5 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-30-2010, 10:59 AM   #2
iRV2 Marketing
 
DriVer's Avatar
 
Winnebago Owners Club
Workhorse Chassis Owner
Coastal Campers
Carolina Campers
Join Date: Jan 2000
Location: Conway, SC
Posts: 23,304
Blog Entries: 70
Quote:
Originally Posted by allegro5 View Post
Out of nowhere my 96 Dynasty heater blower stopped ! With Key and blower switch all on, I used a test light to all the wires in the connector to the resistor at the Heater core box in the firewall in the Gen bay, and nothing hot ! In the front run bay outside and below the drivers window, with the engine running, all the fuses were dead, and were also dead with the key off, in the bank of fuses on the lower right! In the center bar of fuses, the only one hot was the 15Amp #3 fuse with key off and on! With key off, all the fuses in the left bank of fuses, were Hot! and cold with the Engine running! I say running so its clear the key was on! If anyone can answer the reasons so I can get this deal working, I will send you twenty bucks, if so permitted! I am not very good with electronics!
I have seen where the modular connector has come off the back of the switch - take a look see!
__________________

__________________
03 Adventurer 38G, Workhorse W22
F&R Track Bars, Safety+ , Ultrapower, Taylor Extremes, SGII
TST 507, Blue Ox, SMI, Koni FSD, CrossFire
RV/MH Hall of Fame - Lifetime Member
DriVer is offline   Reply With Quote
Old 07-01-2010, 07:08 AM   #3
Senior Member
 
Monaco Owners Club
Join Date: Jun 2010
Posts: 178
Blog Entries: 2
Hi Friends, In the front run bay where the 3 banks of fuses and some relays are, two of the bars of fuses are not hot, with Key on or off! Also the connector plug to the resistor on the heater core box has no power with the key on and the dask blower set in any position! Where and what device energizes the rows of fuses in that front run bay of fuses and relays? I have changed the two Solenoids in the engine bay, Who do I go to for answers? Allegro5 Thanks for any advice
__________________
allegro5 is offline   Reply With Quote
Old 07-05-2010, 11:57 AM   #4
Member
 
Join Date: Nov 2007
Location: Montreal/Florida
Posts: 31
Quote:
Originally Posted by allegro5 View Post
Hi Friends, In the front run bay where the 3 banks of fuses and some relays are, two of the bars of fuses are not hot, with Key on or off! Also the connector plug to the resistor on the heater core box has no power with the key on and the dash blower set in any position! Where and what device energizes the rows of fuses in that front run bay of fuses and relays? I have changed the two Solenoids in the engine bay, Who do I go to for answers? Allegro5 Thanks for any advice
Looks like you are not getting many answers here!! But one place you might try is a FUSIBLE link. The fuse panel is likely fed by some other bigger fuse somewhere. A fusible link of the type I have seen looks very much like a larger wire and sometimes has a plastic tag moulded in as part of the assemby with either a part number or amps on it. It is not always obvious it has gone.

You might also try Tiffen if they supplied this particular fuse panel.

Good luck in finding it!!!
__________________
Alfa 38 5ver (Florida)
Montreal/Florida Snowbird
Alfa38User is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Propane heater cycles on & off dsbike RV Systems & Appliances 10 05-26-2010 11:29 AM
Suburban heater cycles on & off dsbike Winnebago Industries Owner's Forum 5 05-12-2010 09:08 PM
Dash Air blower motor jupoa Ford Motorhome Chassis Forum 3 07-07-2009 11:50 PM
Dash heater help? HarveyP MH-General Discussions & Problems 1 12-02-2007 04:58 PM
Dash A/C and heater concerns on 03 40fdts Stretch Alpine Coach Owner's Forum 2 04-15-2006 05:49 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:55 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.