Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 10-11-2015, 04:35 PM   #1
pro_coupe 34's Avatar
Join Date: Nov 2012
Location: Pa.
Posts: 69
Instrument gauges stop working

Wasn,t a good Sunday morning start. Fired up the motorhome only to find out none of dash gauges were responding. No RPM no oil pres no nothing. Had alot of support from other campers, So we check all fuses and found nothing bad.... So Im 170 miles from home. Yes I chanced it, Once I got home I removed all the cobwebs from my brain. Few hrs later I used the old poke and hope method. I switch 2 relays that had the same diagram and numbers. Presto its like magic All gauges are once again responding. F57b-14b192-aa relay bad.

pro_coupe 34 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-11-2015, 05:00 PM   #2
Junior Member
Join Date: Jan 2014
Location: Montgomery, Tx
Posts: 15
Good move. Sounds like me taking a chance. I had a relay go out on my Park signal, low air pressure, and heat gauge in the upper heat zone and I was 600 miles away from home. Freightliner replaced Park relay at price of 200 dollars but left the other undone.

Congratulations on getting the cobwebs out and figuring out how to correct the problem.
voncluck is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freightliner Dash Gauges Not Working LPD218 Freightliner Motorhome Chassis Forum 7 06-12-2015 03:18 PM
Dash gauges do not work wilson8ford Class A Motorhome Discussions 37 10-29-2014 08:43 AM
1999 SAFARI 425 CONTINENTAL dash gauges POPPASMURF Class A Motorhome Discussions 3 09-08-2014 04:20 AM
Gauges quick working on our 2002 Alpine Coach Randy509 Alpine Coach Owner's Forum 2 03-28-2014 03:10 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:47 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.