Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 05-24-2011, 12:53 PM   #1
Senior Member
Join Date: Jul 2003
Location: Commerce Twp, MI
Posts: 309
intermittent HWH won't extend issue

My HWH jack has a intermittent issue. I just used it and then couple minutes later, it won't work. Parking brake is on. HWH panel is ON. when I push any of the extend jack buttons, I can hear it click, but no jack movement. HWH slide outs work fine. After many tries, finally the jack does extend. It happened once on a previous trip and just happened again today. What could be going bad? What should I test, look at? Thanks.

It's been frustrating lately, as it seems the gremlins are making a return trip to my MH !!

2012 Winnebago Adventurer 35P, Roadmaster F+R sway bars, Blue Ox Tiger Trac, 06 HHR toad
past:2003 Itasca Suncruiser 38G
LandHo is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-24-2011, 01:00 PM   #2
Senior Member
GaryKD's Avatar
Newmar Owners Club
Join Date: Jul 2006
Location: Wellington, Florida
Posts: 11,772
Hi LandHo,
Do you hear any noise(s) besides the click. Does the pump run? HWH is notorious for having bad ground connections to the chassis.

2005 Newmar KSDP 3910 + GMC ENVOY XUV 37K lbs Moving Down The Road
The Avatar Is Many Times Around The USA
Nobody Knows Your Coach Like Somebody Who Owns One Just Like Yours
GaryKD is offline   Reply With Quote
Old 05-24-2011, 03:42 PM   #3
Senior Member
Join Date: Jul 2003
Location: Commerce Twp, MI
Posts: 309
pump does not run. where is the ground? in that mess near the pump/tank?
maybe I should clean the ground.
2012 Winnebago Adventurer 35P, Roadmaster F+R sway bars, Blue Ox Tiger Trac, 06 HHR toad
past:2003 Itasca Suncruiser 38G
LandHo is offline   Reply With Quote
Old 07-16-2011, 05:09 PM   #4
Senior Member
Workhorse Chassis Owner
Join Date: Jan 2007
Posts: 295

I think I'm having the same problem that you have/are having.

Set the parking brake, Turn on key, turn on pad to "level", push the jack down button and I get nothing but a click or knock like the sound of a solinoid engaging. Sometime the hyd motor will come on for a second, sometime it works okay but now it usually doesn't work.

I have removed, cleaned and reconneted the battery cables and the connections on the back of the keypad.

I need a spider monkey to reach the connections at the hyd pump.

Have you resolved your issues? Any suggestion for me?

This is an HWH 325 Manual system.

2003 Allegro, 32BA, W20,'06 Saturn Vue, Demco Aluminator, RM9700, R1150RT B'mer
SE Louisiana
RottenRalph is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
HWH Jacks not storing, panel not lit JRS 39K MH-General Discussions & Problems 3 10-12-2010 09:05 AM
HWH Leveling Issue waynehartwig MH-General Discussions & Problems 7 09-07-2010 10:22 PM
HWH Hydraulic Leak - can't pinpoint the leak Dale777 Alpine Coach Owner's Forum 1 08-11-2010 06:14 PM
HWH Factory Service robbstein Winnebago Industries Owner's Forum 5 06-06-2009 08:16 AM
HWH Jack retraction tip RanchoVectra Winnebago Industries Owner's Forum 16 03-15-2007 05:30 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:19 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.